summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/asmem/asmem-1.12.ebuild')
-rw-r--r--x11-plugins/asmem/asmem-1.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/asmem/asmem-1.12.ebuild b/x11-plugins/asmem/asmem-1.12.ebuild
new file mode 100644
index 000000000000..4cc5daffb073
--- /dev/null
+++ b/x11-plugins/asmem/asmem-1.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asmem/asmem-1.12.ebuild,v 1.1 2008/01/17 02:59:49 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a swallowable applet monitors the utilization level of memory, cache and swap space."
+HOMEPAGE="http://www.tigr.net"
+SRC_URI="http://www.tigr.net/afterstep/download/asmem/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm
+ x11-libs/libXext
+ jpeg? ( media-libs/jpeg )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_compile() {
+ tc-export CC
+ econf $(use_enable jpeg)
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.man ${PN}.1
+ dodoc CHANGES README
+}