summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild')
-rw-r--r--x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild b/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
index a613731e965a..5177145cdecf 100644
--- a/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
+++ b/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild,v 1.4 2010/08/16 20:33:35 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild,v 1.5 2012/04/20 11:04:08 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit autotools
MY_P=candido-engine-${PV}
-DESCRIPTION="Candido GTK+ Theme Engine"
-HOMEPAGE="http://candido.berlios.de"
+DESCRIPTION="Candido GTK+ 2.x Theme Engine"
+HOMEPAGE="http://candido.berlios.de/"
SRC_URI="mirror://berlios/candido/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86 ~x86-interix ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 x86 ~x86-interix ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2.8:2"
@@ -22,15 +22,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+DOCS="AUTHORS ChangeLog CREDITS NEWS README"
+
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch
eautoreconf # required for interix
}
src_configure() {
- econf --disable-dependency-tracking --enable-animation
+ econf --enable-animation
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog CREDITS NEWS README
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
}