summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/oroborus/oroborus-2.0.20.ebuild')
-rw-r--r--x11-wm/oroborus/oroborus-2.0.20.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/oroborus/oroborus-2.0.20.ebuild b/x11-wm/oroborus/oroborus-2.0.20.ebuild
new file mode 100644
index 000000000000..cd7d36996470
--- /dev/null
+++ b/x11-wm/oroborus/oroborus-2.0.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/oroborus/oroborus-2.0.20.ebuild,v 1.1 2010/05/31 10:07:19 xarthisius Exp $
+
+DESCRIPTION="Small and fast window manager."
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gnome"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ if use gnome; then
+ insinto /usr/share/gnome/wm-properties
+ doins "${FILESDIR}"/${PN}.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog example.${PN}rc README TODO || die
+}