summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog9
-rw-r--r--x11-wm/dwm/dwm-5.9.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 364eff7304d9..447d9457f080 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.68 2010/10/21 21:39:36 cedk Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.69 2011/07/19 12:54:05 jer Exp $
+
+*dwm-5.9 (19 Jul 2011)
+
+ 19 Jul 2011; Jeroen Roovers <jer@gentoo.org> +dwm-5.9.ebuild:
+ Version bump.
21 Oct 2010; Cédric Krier <cedk@gentoo.org> dwm-5.7.2.ebuild,
dwm-5.8.2.ebuild:
diff --git a/x11-wm/dwm/dwm-5.9.ebuild b/x11-wm/dwm/dwm-5.9.ebuild
new file mode 100644
index 000000000000..2c8c69852b5e
--- /dev/null
+++ b/x11-wm/dwm/dwm-5.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-5.9.ebuild,v 1.1 2011/07/19 12:54:05 jer Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://www.suckless.org/dwm/"
+SRC_URI="http://dl.suckless.org/dwm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? (
+ x11-proto/xineramaproto
+ x11-libs/libXinerama
+ )"
+RDEPEND="${DEPEND}
+ x11-apps/xsetroot"
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "/^LDFLAGS/{s|=|+=|g;s|-s ||g}" \
+ -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ -e "s@/usr/X11R6/include@/usr/include/X11@" \
+ -e "s@/usr/X11R6/lib@/usr/lib@" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC)
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS=""
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+ einfo "Since dwm-5.4, status info in the bar must be set like this:"
+ einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
+}