summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-time-out-plugin')
-rw-r--r--xfce-extra/xfce4-time-out-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-time-out-plugin/files/xfce4-time-out-plugin-1.0.0-assertion_percentage_failed.patch13
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.0-r1.ebuild28
3 files changed, 50 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/ChangeLog b/xfce-extra/xfce4-time-out-plugin/ChangeLog
index ecb3de11c272..186c6fa7337e 100644
--- a/xfce-extra/xfce4-time-out-plugin/ChangeLog
+++ b/xfce-extra/xfce4-time-out-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-time-out-plugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-time-out-plugin/ChangeLog,v 1.10 2011/04/23 17:44:02 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-time-out-plugin/ChangeLog,v 1.11 2012/02/15 04:57:04 ssuominen Exp $
+
+*xfce4-time-out-plugin-1.0.0-r1 (15 Feb 2012)
+
+ 15 Feb 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-time-out-plugin-1.0.0-r1.ebuild,
+ +files/xfce4-time-out-plugin-1.0.0-assertion_percentage_failed.patch:
+ Fix assertion "percentage" failure wrt #402859 by Arthur Demchenkov
23 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-time-out-plugin-1.0.0.ebuild:
diff --git a/xfce-extra/xfce4-time-out-plugin/files/xfce4-time-out-plugin-1.0.0-assertion_percentage_failed.patch b/xfce-extra/xfce4-time-out-plugin/files/xfce4-time-out-plugin-1.0.0-assertion_percentage_failed.patch
new file mode 100644
index 000000000000..14fa2a15adf6
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/files/xfce4-time-out-plugin-1.0.0-assertion_percentage_failed.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=402859
+http://bugzilla.xfce.org/show_bug.cgi?id=7660
+
+--- panel-plugin/time-out-lock-screen.c
++++ panel-plugin/time-out-lock-screen.c
+@@ -313,6 +313,7 @@
+ GString *time_string;
+
+ g_return_if_fail (IS_TIME_OUT_LOCK_SCREEN (lock_screen));
++ if (seconds < 0) return;
+
+ /* Set remaining seconds attribute */
+ lock_screen->remaining_seconds = seconds;
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.0-r1.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..882c9da6111f
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.0-r1.ebuild,v 1.1 2012/02/15 04:57:04 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-time-out-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-assertion_percentage_failed.patch )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}