summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pmount/pmount-0.8.ebuild')
-rw-r--r--sys-apps/pmount/pmount-0.8.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-apps/pmount/pmount-0.8.ebuild b/sys-apps/pmount/pmount-0.8.ebuild
deleted file mode 100644
index 5cf3b3e..0000000
--- a/sys-apps/pmount/pmount-0.8.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.3-r1.ebuild,v 1.2 2005/08/25 22:05:53 cardoe Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
-SRC_URI="http://www.piware.de/projects/${P}.tar.gz"
-HOMEPAGE="http://www.piware.de/projects.shtml"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="x86"
-IUSE="hal"
-
-RDEPEND="hal? ( =sys-apps/hal-0.4* )
- >=sys-fs/sysfsutils-1.0"
-
-DEPEND=${RDEPEND}
-
-DOCS="AUTHORS CHANGES"
-
-pkg_setup() {
- enewgroup plugdev || die "Error creating plugdev group"
- append-ldflags "-Wl,-z,now"
-}
-
-src_compile() {
- make pmount pumount || die "Failed to make pmount and pumount"
-
- if use hal; then
- make pmount-hal || die "Failed to make pmount-hal"
- fi
-}
-
-src_install () {
- #this is where we mount stuff
- keepdir /media
-
- # HAL informed mounter, used by Gnome/KDE
- use hal && dobin pmount-hal
-
- # Must be run SETUID
- exeinto /usr/bin
- exeopts -m 4710 -g plugdev
- doexe pmount pumount
-
- dodoc AUTHORS CHANGES || die "docs are not found"
- doman pmount.1 pumount.1
- use hal && doman pmount-hal.1
-
- insinto /etc
- doins pmount.allow
-}
-
-pkg_postinst() {
- einfo
- einfo "This package has been installed setuid. The permissions are as such that"
- einfo "only users that belong to the plugdev group are allowed to run this."
- einfo
- einfo "Please add your user to the plugdev group to be able to mount USB drives"
-}
-
-pkg_postrm() {
- einfo "The /media dir is left to the system because it prevents it from"
- einfo "getting deleted when updating."
-}