summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2020-06-12 11:21:15 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2020-06-12 11:22:04 +0300
commit2524221aa74936afd2fd45134c2833b496907d02 (patch)
tree1be05479fbae13447ef70146a006916cf8547015
parentmedia-video/mplayer: migrate to git-r3 (diff)
downloadbircoph-2524221aa74936afd2fd45134c2833b496907d02.tar.gz
bircoph-2524221aa74936afd2fd45134c2833b496907d02.tar.bz2
bircoph-2524221aa74936afd2fd45134c2833b496907d02.zip
Remove clsync live packages as they are upstream now
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--app-admin/clsync/clsync-9999.ebuild108
-rw-r--r--app-admin/clsync/files/clsync.conf18
-rw-r--r--app-admin/clsync/files/clsync.confd20
-rw-r--r--app-admin/clsync/files/clsync.initd17
-rw-r--r--app-admin/clsync/metadata.xml30
-rw-r--r--app-doc/clsync-docs/clsync-docs-9999.ebuild49
-rw-r--r--app-doc/clsync-docs/metadata.xml18
-rw-r--r--dev-libs/libclsync/libclsync-9999.ebuild78
-rw-r--r--dev-libs/libclsync/metadata.xml19
-rw-r--r--profiles/categories3
10 files changed, 0 insertions, 360 deletions
diff --git a/app-admin/clsync/clsync-9999.ebuild b/app-admin/clsync/clsync-9999.ebuild
deleted file mode 100644
index 7fd74d2..0000000
--- a/app-admin/clsync/clsync-9999.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/xaionaro/${PN}.git"
-else
- SRC_URI="https://github.com/xaionaro/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit autotools linux-info
-
-DESCRIPTION="Live sync tool based on inotify, written in GNU C"
-HOMEPAGE="https://github.com/xaionaro/clsync http://ut.mephi.ru/oss/clsync"
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="+caps cluster control-socket cgroups debug extra-debug
-extra-hardened gio hardened +highload-locks +inotify mhash
-namespaces seccomp"
-
-REQUIRED_USE="
- || ( gio inotify )
- extra-debug? ( debug )
- extra-hardened? ( hardened )
- mhash? ( cluster )
- seccomp? ( caps )
-"
-CDEPEND="
- dev-libs/glib:2
- cgroups? ( dev-libs/libcgroup )
- mhash? ( app-crypt/mhash )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}
- ~app-doc/clsync-docs-${PV}
-"
-
-pkg_pretend() {
- use namespaces && CONFIG_CHECK="~NAMESPACES ~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- use seccomp && CONFIG_CHECK+=" ~SECCOMP"
- check_extra_config
-}
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- local harden_level=0
- use hardened && harden_level=1
- use extra-hardened && harden_level=2
-
- local debug_level=0
- use debug && debug_level=1
- use extra-debug && debug_level=2
-
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --disable-socket-library \
- --enable-clsync \
- --enable-debug=${debug_level} \
- --enable-paranoid=${harden_level} \
- --without-bsm \
- --without-kqueue \
- $(use_enable caps capabilities) \
- $(use_enable cluster) \
- $(use_enable control-socket socket) \
- $(use_enable highload-locks) \
- $(use_enable namespaces unshare) \
- $(use_enable seccomp) \
- $(use_with cgroups libcgroup) \
- $(use_with gio gio lib) \
- $(use_with inotify inotify native) \
- $(use_with mhash)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # docs go into clsync-docs
- rm -rf "${ED}/usr/share/doc" || die
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
-
- # filter rules and sync scripts are supposed to be here
- keepdir "${EPREFIX}/etc/${PN}"
- insinto "/etc/${PN}"
- newins "${FILESDIR}/${PN}.conf" "${PN}.conf"
-}
-
-pkg_postinst() {
- einfo "${PN} is just a convenient way to run synchronization tools on live data,"
- einfo "it doesn't copy data itself, so you need to install software to do actual"
- einfo "data transfer. Usually net-misc/rsync is a good choise, but ${PN} is"
- einfo "is flexible enough to use any user tool, see manual page for details."
- einfo
- einfo "${PN} init script can be multiplexed, to use symlink init script to"
- einfo "othername and use conf.d/othername to configure it."
- einfo
- einfo "If you're interested in improved security, enable"
- einfo "USE=\"caps cgroups hardened namespaces seccomp\""
-}
diff --git a/app-admin/clsync/files/clsync.conf b/app-admin/clsync/files/clsync.conf
deleted file mode 100644
index 91f38f1..0000000
--- a/app-admin/clsync/files/clsync.conf
+++ /dev/null
@@ -1,18 +0,0 @@
-# clsync system configuration file
-#
-# General recommendations:
-# 1. Put --dir-lists on tmpfs.
-# 2. Use --uid and --gid to drop privileges whenever possible.
-# 3. Keeep your clsync rules and sync scripts in /etc/clsync/.
-
-[default]
-# Put your options here, see clsync man pages for a list of valid options.
-# Also check examples directory (/usr/share/doc/clsync-*/examples).
-#
-#watch-dir = /what/dir/to/sync
-#sync-handler = /etc/clsync/action.sh
-#rules-dir = /etc/clsync/rules
-#lists-dir = /tmp/clsync
-#threading = safe
-#delay-sync = 5
-#delay-collect = 5
diff --git a/app-admin/clsync/files/clsync.confd b/app-admin/clsync/files/clsync.confd
deleted file mode 100644
index 389f84e..0000000
--- a/app-admin/clsync/files/clsync.confd
+++ /dev/null
@@ -1,20 +0,0 @@
-# /etc/conf.d/clsync: config file for /etc/init.d/clsync
-
-# config file, default is /etc/clsync/clsync.conf.
-# to disable set to /dev/null
-#CLSYNC_CONF="/etc/clsync/clsync.conf"
-
-# clsync options, have precedence over config file,
-# see man clsync and $docdir/examples for details
-#CLSYNC_OPTS=""
-
-# Example of direct rsync usage:
-#CLSYNC_OPTS="--lists-dir /tmp/clsync --mode rsyncshell
-#--watch-dir /source/dir --sync-handler /usr/bin/rsync
-#--rules-file /etc/clsync/rules --distination-dir /destination/dir"
-
-# Change clsync nice level (default is unset)
-#CLSYNC_NICE="0"
-
-# Change clsync ionice level (default is unset)
-#CLSYNC_IONICE="2:7"
diff --git a/app-admin/clsync/files/clsync.initd b/app-admin/clsync/files/clsync.initd
deleted file mode 100644
index 28175a5..0000000
--- a/app-admin/clsync/files/clsync.initd
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-[ -n "${CLSYNC_CONF}" ] && conffile="--config-file ${CLSYNC_CONF}"
-[ -n "${CLSYNC_NICE}" ] && cmd_nice="--nice ${CLSYNC_NICE}"
-[ -n "${CLSYNC_IONICE}" ] && cmd_ionice="--ionice ${CLSYNC_IONICE}"
-
-command="/usr/bin/clsync"
-pidfile="/var/run/${SVCNAME}.pid"
-command_args="--background --output=syslog --pid-file=${pidfile} \
-${conffile} ${CLSYNC_OPTS}"
-start_stop_daemon_args="${cmd_nice} ${cmd_ionice}"
-
-depend() {
- use net
-}
diff --git a/app-admin/clsync/metadata.xml b/app-admin/clsync/metadata.xml
deleted file mode 100644
index 9cbe60e..0000000
--- a/app-admin/clsync/metadata.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
- <longdescription>
- Clsync recursively watches for source directory and executes external
- program to sync the changes. Clsync is adapted to be used together with rsync.
- This utility is much more lightweight than competitors and supports such
- features as separate queue for big files, regex file filter, multi-threading
- and multicast notifing clsync instances on another nodes to prevent loop
- syncing. Clsync can use advanced features for isolation: capabilities, cgroups,
- namespaces, seccomp, code hardening.
-</longdescription>
- <use>
- <flag name="cluster">Enable clustering support (allows master-master clsync on multiple hosts). Not fully implemented yet.</flag>
- <flag name="control-socket">Enable AF_UNIX control socket support.</flag>
- <flag name="cgroups">Use cgroups to limit /dev access.</flag>
- <flag name="extra-debug">Enable extra debugging. This will hurt performance badly. Be ready for tons of output.</flag>
- <flag name="extra-hardened">Enable extra security checks. This will hurt performance.</flag>
- <flag name="gio">Enable GIO for FS monitoring (glib based alternative to inotify interface, not recommended; if both are compiled, may be selected at runtime).</flag>
- <flag name="highload-locks">Allows to use spinlocks for short delays instead of mutexes, but only on SMP systems.</flag>
- <flag name="namespaces">Enable namespaces isolation.</flag>
- </use>
- <upstream>
- <remote-id type="github">xaionaro/clsync</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-doc/clsync-docs/clsync-docs-9999.ebuild b/app-doc/clsync-docs/clsync-docs-9999.ebuild
deleted file mode 100644
index 3a65d80..0000000
--- a/app-doc/clsync-docs/clsync-docs-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_PN="${PN%-docs}"
-MY_P="${MY_PN}-${PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
-else
- SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="Clsync and libclsync API documentation"
-HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="api +examples"
-
-DEPEND="
- virtual/pkgconfig
- api? ( app-doc/doxygen )
-"
-
-src_configure() {
- : # doxygen doesn't depend on configuration
-}
-
-src_compile() {
- if use api; then
- doxygen .doxygen || die "doxygen failed"
- fi
-}
-
-src_install() {
- dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
- if use api; then
- dohtml -r doc/doxygen/html/*
- dodoc -r doc/devel/*
- fi
- if use examples; then
- docinto examples
- dodoc -r examples/{production,clsync*}
- fi
-}
diff --git a/app-doc/clsync-docs/metadata.xml b/app-doc/clsync-docs/metadata.xml
deleted file mode 100644
index 7d716da..0000000
--- a/app-doc/clsync-docs/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
- <longdescription>
- Install documentation common for <pkg>app-admin/clsync</pkg> and
- <pkg>dev-libs/libclsync</pkg> packages.
-</longdescription>
- <use>
- <flag name="api">Install doxygen generated API docs.</flag>
- </use>
- <upstream>
- <remote-id type="github">xaionaro/clsync</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/libclsync/libclsync-9999.ebuild b/dev-libs/libclsync/libclsync-9999.ebuild
deleted file mode 100644
index 028c59b..0000000
--- a/dev-libs/libclsync/libclsync-9999.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_PN=${PN#lib}
-MY_P="${MY_PN}-${PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
-else
- SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-inherit autotools
-
-DESCRIPTION="Control and monitoring library for clsync"
-HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug extra-debug extra-hardened hardened static-libs"
-REQUIRED_USE="
- extra-debug? ( debug )
- extra-hardened? ( hardened )
-"
-
-DEPEND="virtual/pkgconfig "
-RDEPEND="~app-doc/clsync-docs-${PV}"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- local harden_level=0
- use hardened && harden_level=1
- use extra-hardened && harden_level=2
-
- local debug_level=0
- use debug && debug_level=1
- use extra-debug && debug_level=2
-
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-socket-library \
- --disable-clsync \
- --enable-debug=${debug_level} \
- --enable-paranoid=${harden_level} \
- --without-bsm \
- --without-kqueue \
- --disable-capabilities \
- --disable-cluster \
- --enable-socket \
- --disable-highload-locks \
- --disable-unshare \
- --disable-seccomp \
- --without-libcgroup \
- --without-gio \
- --with-inotify=native \
- --without-mhash
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files
- use static-libs || find "${ED}" -name "*.a" -delete || die "failed to remove static libs"
-
- # docs go into clsync-docs
- rm -rf "${ED}/usr/share/doc" || die
-}
-
-pkg_postinst() {
- einfo "clsync instances you are going to use _must_ be compiled"
- einfo "with control-socket support"
-}
diff --git a/dev-libs/libclsync/metadata.xml b/dev-libs/libclsync/metadata.xml
deleted file mode 100644
index 8c5ebe0..0000000
--- a/dev-libs/libclsync/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
- <longdescription>
- Libclsync is a library for remote control and monitoring of
- <pkg>app-admin/clsync</pkg> processes.
-</longdescription>
- <use>
- <flag name="extra-debug">Enable extra debugging. This will hurt performance badly. Be ready for tons of output.</flag>
- <flag name="extra-hardened">Enable extra security checks. This may hurt performance.</flag>
- </use>
- <upstream>
- <remote-id type="github">xaionaro/clsync</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/categories b/profiles/categories
index 9e2ce5e..9376d74 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,10 +1,7 @@
-app-admin
-app-doc
app-emulation
app-i18n
app-text
app-vim
-dev-libs
dev-python
dev-util
mail-client