summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2010-10-28 15:23:00 +0100
committerRobert Piasek <dagger@gentoo.org>2010-10-28 15:23:00 +0100
commit5025d0a33fe5ae6d973b61c6b5ec2f153fc3161a (patch)
tree3f7829542b324bfd883bf774e36d5e1b978ccb69
parentVersion bump for Zarafa and zarafa-webaccess. (diff)
downloaddagger-5025d0a33fe5ae6d973b61c6b5ec2f153fc3161a.tar.gz
dagger-5025d0a33fe5ae6d973b61c6b5ec2f153fc3161a.tar.bz2
dagger-5025d0a33fe5ae6d973b61c6b5ec2f153fc3161a.zip
New version of zarafa collaboration platform
-rw-r--r--net-mail/zarafa/ChangeLog6
-rw-r--r--net-mail/zarafa/files/zarafa-6.40.1-no-php-conf.patch44
-rw-r--r--net-mail/zarafa/zarafa-6.40.3.ebuild87
3 files changed, 137 insertions, 0 deletions
diff --git a/net-mail/zarafa/ChangeLog b/net-mail/zarafa/ChangeLog
index 0d3164c..7555308 100644
--- a/net-mail/zarafa/ChangeLog
+++ b/net-mail/zarafa/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zarafa-6.40.3 (28 Oct 2010)
+
+ 28 Oct 2010; Robert Piasek <dagger@gentoo.org>
+ +files/zarafa-6.40.1-no-php-conf.patch, +zarafa-6.40.3.ebuild:
+ Added version 6.40.3.
+
11 Aug 2010; Robert Piasek <dagger@gentoo.org> zarafa-6.40.1.ebuild:
Updated libical dependency. It seems 0.44 is required to make it work ok
diff --git a/net-mail/zarafa/files/zarafa-6.40.1-no-php-conf.patch b/net-mail/zarafa/files/zarafa-6.40.1-no-php-conf.patch
new file mode 100644
index 0000000..9e51f09
--- /dev/null
+++ b/net-mail/zarafa/files/zarafa-6.40.1-no-php-conf.patch
@@ -0,0 +1,44 @@
+--- php-ext/Makefile.in~ 2010-10-20 12:26:22.000000000 +0100
++++ php-ext/Makefile.in 2010-10-28 13:40:48.830318647 +0100
+@@ -34,7 +34,7 @@
+ build_triplet = @build@
+ host_triplet = @host@
+ subdir = php-ext
+-DIST_COMMON = $(dist_data_DATA) $(dist_sysconf_DATA) \
++DIST_COMMON = $(dist_data_DATA) \
+ $(srcdir)/Makefile.am $(srcdir)/Makefile.in
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/configure.ac
+@@ -86,7 +86,7 @@
+ DIST_SOURCES = $(mapi_la_SOURCES)
+ dist_dataDATA_INSTALL = $(INSTALL_DATA)
+ dist_sysconfDATA_INSTALL = $(INSTALL_DATA)
+-DATA = $(dist_data_DATA) $(dist_sysconf_DATA)
++DATA = $(dist_data_DATA)
+ ETAGS = etags
+ CTAGS = ctags
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+@@ -406,23 +406,6 @@
+ echo " rm -f '$(DESTDIR)$(datadir)/$$f'"; \
+ rm -f "$(DESTDIR)$(datadir)/$$f"; \
+ done
+-install-dist_sysconfDATA: $(dist_sysconf_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
+- @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f=$(am__strip_dir) \
+- echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
+- done
+-
+-uninstall-dist_sysconfDATA:
+- @$(NORMAL_UNINSTALL)
+- @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+- f=$(am__strip_dir) \
+- echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- rm -f "$(DESTDIR)$(sysconfdir)/$$f"; \
+- done
+
+ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
diff --git a/net-mail/zarafa/zarafa-6.40.3.ebuild b/net-mail/zarafa/zarafa-6.40.3.ebuild
new file mode 100644
index 0000000..50d8ef9
--- /dev/null
+++ b/net-mail/zarafa/zarafa-6.40.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+PHP_EXT_NAME="mapi"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit eutils php-ext-base-r1
+
+DESCRIPTION="Open Source Groupware Solution"
+HOMEPAGE="http://zarafa.com/"
+SRC_URI="http://dev.gentoo.org/~dagger/files/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug ldap +logrotate static"
+
+RDEPEND=">=dev-libs/libical-0.44
+ =dev-cpp/libvmime-0.7.1
+ >=dev-lang/php-5.2.0
+ app-text/catdoc
+ app-text/poppler
+ dev-cpp/clucene
+ dev-db/mysql
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ logrotate? ( app-admin/logrotate )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # Fixes zarafa-server linking
+ epatch "${FILESDIR}"/"${PN}"-6.40.1-uuid-link.patch
+
+ # Don't install php ini file, as installation doesn't
+ # respect Gentoo way of handling SAPIs
+ epatch "${FILESDIR}"/"${PN}"-6.40.1-no-php-conf.patch
+}
+
+src_configure() {
+ econf \
+ --enable-oss \
+ --disable-perl \
+ --disable-testtools \
+ --with-userscript-prefix=/etc/zarafa/userscripts \
+ --with-quotatemplate-prefix=/etc/zarafa/quotamails \
+ --with-indexerscripts-prefix=/etc/zarafa/indexerscripts \
+ $(use_enable static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # Install PHP module
+ php-ext-base-r1_src_install
+ php-ext-base-r1_addtoinifiles ";mapi.cache_max_sessions" "128"
+ php-ext-base-r1_addtoinifiles ";mapi.cache_lifetime" "300"
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/zarafa.logrotate zarafa || die "Failed to install logrotate"
+ fi
+
+ insinto /etc/zarafa
+ doins "${S}"/installer/linux/*.cfg || die "Failed to install config files"
+
+ dodir /var/log/zarafa
+ keepdir /var/log/zarafa
+
+ newinitd "${FILESDIR}"/zarafa-gateway.rc6 zarafa-gateway
+ newinitd "${FILESDIR}"/zarafa-ical.rc6 zarafa-ical
+ newinitd "${FILESDIR}"/zarafa-indexer.rc6 zarafa-indexer
+ newinitd "${FILESDIR}"/zarafa-monitor.rc6 zarafa-monitor
+ newinitd "${FILESDIR}"/zarafa-server.rc6 zarafa-server
+ newinitd "${FILESDIR}"/zarafa-spooler.rc6 zarafa-spooler
+
+}