aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-10-16 23:11:25 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-10-16 23:11:25 -0700
commita81d8dcbcd6acb10d69c0f6fa7673198076b926e (patch)
tree1c842dc71fadb50035c1a8503901aafcc6227c27 /eclass
parentbibus: get it closer to working (diff)
downloaddberkholz-a81d8dcbcd6acb10d69c0f6fa7673198076b926e.tar.gz
dberkholz-a81d8dcbcd6acb10d69c0f6fa7673198076b926e.tar.bz2
dberkholz-a81d8dcbcd6acb10d69c0f6fa7673198076b926e.zip
Delete local git and toolchain-binutils eclasses.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/git.eclass286
-rw-r--r--eclass/toolchain-binutils.eclass347
2 files changed, 0 insertions, 633 deletions
diff --git a/eclass/git.eclass b/eclass/git.eclass
deleted file mode 100644
index a4ca6fd..0000000
--- a/eclass/git.eclass
+++ /dev/null
@@ -1,286 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvs/overlay/eclass/git.eclass,v 1.4 2006/05/19 11:36:14 ferdy Exp $
-
-## --------------------------------------------------------------------------- #
-# subversion.eclass author: Akinori Hattori <hattya@gentoo.org>
-# modified for git by Donnie Berkholz <spyderous@gentoo.org>
-# improved by Fernando J. Pereda <ferdy@gentoo.org>
-#
-# The git eclass is written to fetch the software sources from
-# git repositories like the subversion eclass.
-#
-#
-# Description:
-# If you use this eclass, the ${S} is ${WORKDIR}/${P}.
-# It is necessary to define the EGIT_REPO_URI variable at least.
-#
-## --------------------------------------------------------------------------- #
-
-inherit eutils
-
-EGIT="git.eclass"
-
-EXPORT_FUNCTIONS src_unpack
-
-HOMEPAGE="http://git.or.cz/"
-DESCRIPTION="Based on the ${ECLASS} eclass"
-
-
-## -- add git in DEPEND
-#
-DEPEND=">=dev-util/git-1.4.0"
-
-
-## -- EGIT_STORE_DIR: git sources store directory
-#
-EGIT_STORE_DIR="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}/git-src"
-
-
-## -- EGIT_FETCH_CMD: git clone command
-#
-EGIT_FETCH_CMD="git clone --bare"
-
-## -- EGIT_UPDATE_CMD: git fetch command
-#
-EGIT_UPDATE_CMD="git fetch -f -u"
-
-## -- EGIT_DIFFSTAT_CMD: Command to get diffstat output
-#
-EGIT_DIFFSTAT_CMD="git diff --stat"
-
-## -- EGIT_OPTIONS:
-#
-# the options passed to clone and fetch.
-#
-: ${EGIT_OPTIONS:=}
-
-
-## -- EGIT_REPO_URI: repository uri
-#
-# e.g. http://foo, git://bar
-#
-# supported protocols:
-# http://
-# https://
-# git://
-# git+ssh://
-# rsync://
-# ssh://
-#
-: ${EGIT_REPO_URI:=}
-
-
-## -- EGIT_PROJECT: project name of your ebuild
-#
-# git eclass will check out the git repository like:
-#
-# ${EGIT_STORE_DIR}/${EGIT_PROJECT}/${EGIT_REPO_URI##*/}
-#
-# so if you define EGIT_REPO_URI as http://git.collab.net/repo/git or
-# http://git.collab.net/repo/git. and PN is subversion-git.
-# it will check out like:
-#
-# ${EGIT_STORE_DIR}/subversion
-#
-# default: ${PN/-git}.
-#
-: ${EGIT_PROJECT:=${PN/-git}}
-
-
-## -- EGIT_BOOTSTRAP:
-#
-# bootstrap script or command like autogen.sh or etc..
-#
-: ${EGIT_BOOTSTRAP:=}
-
-
-## -- EGIT_PATCHES:
-#
-# git eclass can apply patches in git_bootstrap().
-# you can use regexp in this valiable like *.diff or *.patch or etc.
-# NOTE: this patches will apply before eval EGIT_BOOTSTRAP.
-#
-# the process of applying the patch is:
-# 1. just epatch it, if the patch exists in the path.
-# 2. scan it under FILESDIR and epatch it, if the patch exists in FILESDIR.
-# 3. die.
-#
-: ${EGIT_PATCHES:=}
-
-
-## -- EGIT_BRANCH:
-#
-# git eclass can fetch any branch in git_fetch().
-# Defaults to 'master'
-#
-: ${EGIT_BRANCH:=master}
-
-
-## -- EGIT_TREE:
-#
-# git eclass can checkout any tree.
-# Defaults to EGIT_BRANCH.
-#
-: ${EGIT_TREE:=${EGIT_BRANCH}}
-
-
-## - EGIT_REPACK:
-#
-# git eclass will repack objects to save disk space. However this can take a
-# long time with VERY big repositories. If this is your case set:
-# EGIT_REPACK=false
-#
-: ${EGIT_REPACK:=false}
-
-## - EGIT_PRUNE:
-#
-# git eclass can prune the local clone. This is useful if upstream rewinds and
-# rebases branches too often. If you don't want this to happen, set:
-# EGIT_PRUNE=false
-#
-: ${EGIT_PRUNE:=false}
-
-
-## -- git_fetch() ------------------------------------------------- #
-
-function git_fetch() {
-
- local EGIT_CLONE_DIR
-
- # EGIT_REPO_URI is empty.
- [[ -z ${EGIT_REPO_URI} ]] && die "${EGIT}: EGIT_REPO_URI is empty."
-
- # check for the protocol.
- case ${EGIT_REPO_URI%%:*} in
- git|git+ssh|http|https|rsync|ssh)
- ;;
- *)
- die "${EGIT}: fetch from "${EGIT_REPO_URI%:*}" is not yet implemented."
- ;;
- esac
-
-
- if [[ ! -d ${EGIT_STORE_DIR} ]] ; then
- debug-print "${FUNCNAME}: initial clone. creating git directory"
- addwrite /
- mkdir -p "${EGIT_STORE_DIR}" \
- || die "${EGIT}: can't mkdir ${EGIT_STORE_DIR}."
- chmod -f o+rw "${EGIT_STORE_DIR}" \
- || die "${EGIT}: can't chmod ${EGIT_STORE_DIR}."
- export SANDBOX_WRITE="${SANDBOX_WRITE%%:/}"
- fi
-
- cd -P "${EGIT_STORE_DIR}" || die "${EGIT}: can't chdir to ${EGIT_STORE_DIR}"
- EGIT_STORE_DIR=${PWD}
-
- # every time
- addwrite "${EGIT_STORE_DIR}"
-
- [[ -z ${EGIT_REPO_URI##*/} ]] && EGIT_REPO_URI="${EGIT_REPO_URI%/}"
- EGIT_CLONE_DIR="${EGIT_PROJECT}"
-
- debug-print "${FUNCNAME}: EGIT_OPTIONS = \"${EGIT_OPTIONS}\""
-
- export GIT_DIR="${EGIT_CLONE_DIR}"
-
- if [[ ! -d ${EGIT_CLONE_DIR} ]] ; then
- # first clone
- einfo "git clone start -->"
- einfo " repository: ${EGIT_REPO_URI}"
-
- ${EGIT_FETCH_CMD} ${EGIT_OPTIONS} "${EGIT_REPO_URI}" ${EGIT_PROJECT} \
- || die "${EGIT}: can't fetch from ${EGIT_REPO_URI}."
-
- # We use --bare cloning, so git doesn't do this for us.
- git repo-config remote.origin.url "${EGIT_REPO_URI}"
- else
- # fetch updates
- einfo "git update start -->"
- einfo " repository: ${EGIT_REPO_URI}"
-
- local oldsha1=$(git rev-parse ${EGIT_BRANCH})
-
- ${EGIT_UPDATE_CMD} ${EGIT_OPTIONS} origin ${EGIT_BRANCH}:${EGIT_BRANCH} \
- || die "${EGIT}: can't update from ${EGIT_REPO_URI}."
-
- ${EGIT_DIFFSTAT_CMD} ${oldsha1}..${EGIT_BRANCH}
- fi
-
- einfo " local clone: ${EGIT_STORE_DIR}/${EGIT_CLONE_DIR}"
-
- if ${EGIT_REPACK} ; then
- ebegin "Repacking objects"
- # Strangely enough mv asks confirmation
- yes y | git repack -a -d -f -q > /dev/null
- eend $?
- fi
-
- if ${EGIT_PRUNE} ; then
- ebegin "Removing unreachable objects"
- git prune
- eend $?
- fi
-
- einfo " committish: ${EGIT_TREE}"
-
- # export to the ${WORKDIR}
- mkdir -p "${S}"
- git tar-tree ${EGIT_TREE} | ( cd "${S}" ; tar xf - )
- echo
-
-}
-
-
-## -- git_bootstrap() ------------------------------------------------ #
-
-function git_bootstrap() {
-
- local patch lpatch
-
- cd "${S}"
-
- if [[ -n ${EGIT_PATCHES} ]] ; then
- einfo "apply patches -->"
-
- for patch in ${EGIT_PATCHES} ; do
- if [[ -f ${patch} ]] ; then
- epatch ${patch}
- else
- for lpatch in "${FILESDIR}"/${patch} ; do
- if [[ -f ${lpatch} ]] ; then
- epatch ${lpatch}
- else
- die "${EGIT}: ${patch} is not found"
- fi
- done
- fi
- done
- echo
- fi
-
- if [[ -n ${EGIT_BOOTSTRAP} ]] ; then
- einfo "begin bootstrap -->"
-
- if [[ -f ${EGIT_BOOTSTRAP} ]] && [[ -x ${EGIT_BOOTSTRAP} ]] ; then
- einfo " bootstrap with a file: ${EGIT_BOOTSTRAP}"
- eval "./${EGIT_BOOTSTRAP}" \
- || die "${EGIT}: can't execute EGIT_BOOTSTRAP."
- else
- einfo " bootstrap with commands: ${EGIT_BOOTSTRAP}"
- eval "${EGIT_BOOTSTRAP}" \
- || die "${EGIT}: can't eval EGIT_BOOTSTRAP."
- fi
- fi
-
-}
-
-
-## -- git_src_unpack() ------------------------------------------------ #
-
-function git_src_unpack() {
-
- git_fetch || die "${EGIT}: unknown problem in git_fetch()."
- git_bootstrap || die "${EGIT}: unknown problem in git_bootstrap()."
-
-}
diff --git a/eclass/toolchain-binutils.eclass b/eclass/toolchain-binutils.eclass
deleted file mode 100644
index a6afe1b..0000000
--- a/eclass/toolchain-binutils.eclass
+++ /dev/null
@@ -1,347 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-binutils.eclass,v 1.56 2006/03/10 00:45:31 vapier Exp $
-
-# We install binutils into CTARGET-VERSION specific directories. This lets
-# us easily merge multiple versions for multiple targets (if we wish) and
-# then switch the versions on the fly (with `binutils-config`).
-#
-# binutils-9999 -> live cvs
-# binutils-9999_preYYMMDD -> nightly snapshot date YYMMDD
-# binutils-# -> normal release
-
-extra_eclass=""
-if [[ -n ${BINUTILS_TYPE} ]] ; then
- BTYPE=${BINUTILS_TYPE}
-else
- case ${PV} in
- 9999) BTYPE="cvs";;
- 9999_pre*) BTYPE="snap";;
- *) BTYPE="rel";;
- esac
-fi
-
-if [[ ${BTYPE} == "cvs" ]] ; then
- extra_eclass="cvs"
- ECVS_SERVER="sourceware.org:/cvs/src"
- ECVS_MODULE="binutils"
- ECVS_USER="anoncvs"
- ECVS_PASS="anoncvs"
- BVER="cvs"
-elif [[ ${BTYPE} == "snap" ]] ; then
- BVER=${PV/9999_pre}
-elif [[ ${BTYPE} == "rel" ]] ; then
- BVER=${PV}
-else
- BVER=${BINUTILS_VER}
-fi
-
-inherit eutils libtool flag-o-matic gnuconfig multilib ${extra_eclass}
-EXPORT_FUNCTIONS src_unpack src_compile src_test src_install pkg_postinst pkg_postrm
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-case ${BTYPE} in
- cvs) SRC_URI="";;
- snap) SRC_URI="ftp://gcc.gnu.org/pub/binutils/snapshots/binutils-${BVER}.tar.bz2";;
- rel)
- SRC_URI="mirror://kernel/linux/devel/binutils/binutils-${PV}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/binutils-${PV}.tar.bz2
- mirror://gnu/binutils/binutils-${PV}.tar.bz2"
-esac
-[[ -n ${PATCHVER} ]] && \
- SRC_URI="${SRC_URI} mirror://gentoo/binutils-${PV}-patches-${PATCHVER}.tar.bz2"
-[[ -n ${UCLIBC_PATCHVER} ]] && \
- SRC_URI="${SRC_URI} mirror://gentoo/binutils-${PV}-uclibc-patches-${UCLIBC_PATCHVER}.tar.bz2"
-[[ -n ${ELF2FLT_VER} ]] && \
- SRC_URI="${SRC_URI} mirror://gentoo/elf2flt-${ELF2FLT_VER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-IUSE="nls multitarget multislot test"
-if use multislot ; then
- SLOT="${CTARGET}-${BVER}"
-elif [[ ${CTARGET} != ${CHOST} ]] ; then
- SLOT="${CTARGET}"
-else
- SLOT="0"
-fi
-
-RDEPEND=">=sys-devel/binutils-config-1.8-r6"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/binutils
-[[ ${BVER} != "cvs" ]] && S=${S}-${BVER}
-
-LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${BVER}
-INCPATH=${LIBPATH}/include
-BINPATH=/usr/${CTARGET}/binutils-bin/${BVER}
-DATAPATH=/usr/share/binutils-data/${CTARGET}/${BVER}
-MY_BUILDDIR=${WORKDIR}/build
-
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
-tc-binutils_unpack() {
- unpack ${A}
- mkdir -p "${MY_BUILDDIR}"
- [[ -d ${WORKDIR}/patch ]] && mkdir "${WORKDIR}"/patch/skip
-}
-
-tc-binutils_apply_patches() {
- cd "${S}"
-
- if [[ -n ${PATCHVER} ]] ; then
- EPATCH_SOURCE=${WORKDIR}/patch
- [[ -n $(ls "${EPATCH_SOURCE}"/*.bz2 2>/dev/null) ]] \
- && EPATCH_SUFFIX="patch.bz2" \
- || EPATCH_SUFFIX="patch"
- epatch
- fi
- if [[ -n ${UCLIBC_PATCHVER} ]] ; then
- EPATCH_SOURCE=${WORKDIR}/uclibc-patches
- [[ -n $(ls "${EPATCH_SOURCE}"/*.bz2 2>/dev/null) ]] \
- && EPATCH_SUFFIX="patch.bz2" \
- || EPATCH_SUFFIX="patch"
- EPATCH_MULTI_MSG="Applying uClibc fixes ..." \
- epatch
- elif [[ ${CTARGET} == *-uclibc ]] ; then
- die "sorry, but this binutils doesn't yet support uClibc :("
- fi
-
- # Fix po Makefile generators
- sed -i \
- -e '/^datadir = /s:$(prefix)/@DATADIRNAME@:@datadir@:' \
- -e '/^gnulocaledir = /s:$(prefix)/share:$(datadir):' \
- */po/Make-in || die "sed po's failed"
-
- # Run misc portage update scripts
- gnuconfig_update
- elibtoolize --portage --no-uclibc
-
- # make sure we filter $LINGUAS so that only ones that
- # actually work make it through #42033
- strip-linguas -u */po
-}
-
-toolchain-binutils_src_unpack() {
- tc-binutils_unpack
- tc-binutils_apply_patches
-}
-
-toolchain-binutils_src_compile() {
- strip-flags && replace-flags -O3 -O2 #47581
-
- local x
- echo
- for x in CATEGORY CBUILD CHOST CTARGET CFLAGS LDFLAGS ; do
- einfo "$(printf '%10s' ${x}:) ${!x}"
- done
- echo
-
- cd "${MY_BUILDDIR}"
- local myconf=""
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
- myconf="--prefix=/usr \
- --host=${CHOST} \
- --target=${CTARGET} \
- --datadir=${DATAPATH} \
- --infodir=${DATAPATH}/info \
- --mandir=${DATAPATH}/man \
- --bindir=${BINPATH} \
- --libdir=${LIBPATH} \
- --libexecdir=${LIBPATH} \
- --includedir=${INCPATH} \
- --enable-64-bit-bfd \
- --enable-shared \
- --disable-werror \
- ${myconf} ${EXTRA_ECONF}"
- echo ./configure ${myconf}
- "${S}"/configure ${myconf} || die "configure failed"
-
- # binutils' build system is a bit broken with internal
- # dependencies, so we manually run these first two bfd
- # targets so that we can than use -j# and have it work
- emake -j1 configure-bfd || die "make configure-bfd failed"
- emake -j1 headers -C bfd || die "make headers-bfd failed"
- emake all || die "emake failed"
-
- # only build info pages if we user wants them, and if
- # we have makeinfo (may not exist when we bootstrap)
- if ! has noinfo ${FEATURES} ; then
- if type -p makeinfo ; then
- make info || die "make info failed"
- fi
- fi
- # we nuke the manpages when we're left with junk
- # (like when we bootstrap, no perl -> no manpages)
- find . -name '*.1' -a -size 0 | xargs rm -f
-
- # elf2flt only works on some arches / targets
- if [[ -n ${ELF2FLT_VER} ]] && [[ ${CTARGET} == *linux* || ${CTARGET} == *-elf* ]] ; then
- cd "${WORKDIR}"/elf2flt-${ELF2FLT_VER}
-
- local x supported_arches=$(sed -n '/defined(TARGET_/{s:^.*TARGET_::;s:)::;p}' elf2flt.c | sort -u)
- for x in ${supported_arches} UNSUPPORTED ; do
- [[ ${CTARGET} == ${x}* ]] && break
- done
-
- if [[ ${x} != "UNSUPPORTED" ]] ; then
- append-flags -I"${S}"/include
- myconf="--with-bfd-include-dir=${MY_BUILDDIR}/bfd \
- --with-libbfd=${MY_BUILDDIR}/bfd/libbfd.a \
- --with-libiberty=${MY_BUILDDIR}/libiberty/libiberty.a \
- --with-binutils-ldscript-dir=${LIBPATH}/ldscripts \
- ${myconf}"
- echo ./configure ${myconf}
- ./configure ${myconf} || die "configure elf2flt failed"
- emake || die "make elf2flt failed"
- fi
- fi
-}
-
-toolchain-binutils_src_test() {
- cd "${MY_BUILDDIR}"
- make check || die "check failed :("
-}
-
-toolchain-binutils_src_install() {
- local x d
-
- cd "${MY_BUILDDIR}"
- make DESTDIR="${D}" tooldir="${LIBPATH}" install || die
- rm -rf "${D}"/${LIBPATH}/bin
-
- # Now we collect everything intp the proper SLOT-ed dirs
- # When something is built to cross-compile, it installs into
- # /usr/$CHOST/ by default ... we have to 'fix' that :)
- if is_cross ; then
- cd "${D}"/${BINPATH}
- for x in * ; do
- mv ${x} ${x/${CTARGET}-}
- done
-
- if [[ -d ${D}/usr/${CHOST}/${CTARGET} ]] ; then
- mv "${D}"/usr/${CHOST}/${CTARGET}/include "${D}"/${INCPATH}
- mv "${D}"/usr/${CHOST}/${CTARGET}/lib/* "${D}"/${LIBPATH}/
- rm -r "${D}"/usr/${CHOST}
- fi
- else
- insinto ${INCPATH}
- doins "${S}/include/libiberty.h"
- fi
- if [[ -d ${D}/${LIBPATH}/lib ]] ; then
- mv "${D}"/${LIBPATH}/lib/* "${D}"/${LIBPATH}/
- rm -r "${D}"/${LIBPATH}/lib
- fi
- dodir /usr/${CTARGET}/{bin,include,lib}
- prepman ${DATAPATH}
-
- # Insert elf2flt where appropriate
- if [[ -x ${WORKDIR}/elf2flt-${ELF2FLT_VER}/elf2flt ]] ; then
- cd "${WORKDIR}"/elf2flt-${ELF2FLT_VER}
- insinto ${LIBPATH}/ldscripts
- doins elf2flt.ld || die "doins elf2flt.ld failed"
- exeinto ${BINPATH}
- doexe elf2flt flthdr || die "doexe elf2flt flthdr failed"
- mv "${D}"/${BINPATH}/{ld,ld.real} || die
- newexe ld-elf2flt ld || die "doexe ld-elf2flt failed"
- newdoc README README.elf2flt
- fi
-
- # Now, some binutils are tricky and actually provide
- # for multiple TARGETS. Really, we're talking just
- # 32bit/64bit support (like mips/ppc/sparc). Here
- # we want to tell binutils-config that it's cool if
- # it generates multiple sets of binutil symlinks.
- # e.g. sparc gets {sparc,sparc64}-unknown-linux-gnu
- local targ=${CTARGET/-*} src="" dst=""
- local FAKE_TARGETS=${CTARGET}
- case ${targ} in
- mips*) src="mips" dst="mips64";;
- powerpc*) src="powerpc" dst="powerpc64";;
- s390*) src="s390" dst="s390x";;
- sparc*) src="sparc" dst="sparc64";;
- esac
- case ${targ} in
- mips64*|powerpc64*|s390x*|sparc64*) targ=${src} src=${dst} dst=${targ};;
- esac
- [[ -n ${src}${dst} ]] && FAKE_TARGETS="${FAKE_TARGETS} ${CTARGET/${src}/${dst}}"
-
- # Generate an env.d entry for this binutils
- cd "${S}"
- insinto /etc/env.d/binutils
- cat <<-EOF > env.d
- TARGET="${CTARGET}"
- VER="${BVER}"
- LIBPATH="${LIBPATH}"
- FAKE_TARGETS="${FAKE_TARGETS}"
- EOF
- newins env.d ${CTARGET}-${BVER}
-
- # Handle documentation
- if ! is_cross ; then
- cd "${S}"
- dodoc README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- fi
- # Punt all the fun stuff if user doesn't want it :)
- has noinfo ${FEATURES} && rm -r "${D}"/${DATAPATH}/info
- has noman ${FEATURES} && rm -r "${D}"/${DATAPATH}/man
- # Remove shared info pages
- rm -f "${D}"/${DATAPATH}/info/{dir,configure.info,standards.info}
-}
-
-toolchain-binutils_pkg_postinst() {
- # Make sure this ${CTARGET} has a binutils version selected
- [[ -e ${ROOT}/etc/env.d/binutils/config-${CTARGET} ]] && return 0
- binutils-config ${CTARGET}-${BVER}
-}
-
-toolchain-binutils_pkg_postrm() {
- local current_profile=$(binutils-config -c ${CTARGET})
-
- # If no other versions exist, then uninstall for this
- # target ... otherwise, switch to the newest version
- # Note: only do this if this version is unmerged. We
- # rerun binutils-config if this is a remerge, as
- # we want the mtimes on the symlinks updated (if
- # it is the same as the current selected profile)
- if [[ ! -e ${BINPATH}/ld ]] && [[ ${current_profile} == ${CTARGET}-${BVER} ]] ; then
- local choice=$(binutils-config -l | grep ${CTARGET} | awk '{print $2}')
- choice=${choice//$'\n'/ }
- choice=${choice/* }
- if [[ -z ${choice} ]] ; then
- env -i binutils-config -u ${CTARGET}
- else
- binutils-config ${choice}
- fi
- elif [[ $(CHOST=${CTARGET} binutils-config -c) == ${CTARGET}-${BVER} ]] ; then
- binutils-config ${CTARGET}-${BVER}
- fi
-}