aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/anaconda/Manifest8
-rw-r--r--app-admin/anaconda/anaconda-11.1.0.89.ebuild76
2 files changed, 84 insertions, 0 deletions
diff --git a/app-admin/anaconda/Manifest b/app-admin/anaconda/Manifest
new file mode 100644
index 0000000..fab5827
--- /dev/null
+++ b/app-admin/anaconda/Manifest
@@ -0,0 +1,8 @@
+DIST system-config-date-1.8.5-1.src.rpm 592767 RMD160 302c14af813cd7a62a1c1027ce29722646ee921d SHA1 6abcd3efc7cc9276cfad03d218f8750e505f2e93 SHA256 4386526d059b8dda05377423a9d81e746a95d203511c7c2a4c257664621e9468
+EBUILD system-config-date-1.8.5.ebuild 914 RMD160 4623bda390bcb36cdb5a4045cf1a8fe9615a30d5 SHA1 8aa9ccda170285aca2c35e4f961e56aff235b65c SHA256 67a5ac436d01ff39d959d46e88e8ec692935ae3a15e064337f275f95268dfbf1
+MD5 83044cb49deb384a36c7975a123482f6 system-config-date-1.8.5.ebuild 914
+RMD160 4623bda390bcb36cdb5a4045cf1a8fe9615a30d5 system-config-date-1.8.5.ebuild 914
+SHA256 67a5ac436d01ff39d959d46e88e8ec692935ae3a15e064337f275f95268dfbf1 system-config-date-1.8.5.ebuild 914
+MD5 7f206c6e86e35b81885701ad0cc9fa4c files/digest-system-config-date-1.8.5 283
+RMD160 bec7693e93662ff90e98253cd77e8543f8b8c329 files/digest-system-config-date-1.8.5 283
+SHA256 e82b3b644c6c47d47dc46a49a8138c4bb1e58b3506662ffcf53c3d0d207e0e0c files/digest-system-config-date-1.8.5 283
diff --git a/app-admin/anaconda/anaconda-11.1.0.89.ebuild b/app-admin/anaconda/anaconda-11.1.0.89.ebuild
new file mode 100644
index 0000000..2954615
--- /dev/null
+++ b/app-admin/anaconda/anaconda-11.1.0.89.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="A graphical interface for modifying system date and time"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# bumps: yum, mkinitrd, pyparted
+# circular? s-c-date
+RDEPEND="
+ sys-apps/kudzu
+ sys-apps/pciutils
+ app-arch/bzip2
+ sys-fs/e2fsprogs
+ dev-lang/python
+ =x11-libs/gtk+-2*
+ app-arch/rpm
+ dev-python/rhpl
+??? booty
+ dev-libs/libxml2
+ dev-libs/elfutils
+ dev-libs/beecrypt
+ sys-libs/libselinux
+ x11-libs/libX11
+ x11-libs/libXxf86misc
+ dev-python/urlgrabber
+??? pykickstart
+ >=sys-apps/yum-2.9.2
+ >=sys-fs/device-mapper-1.01.05
+ sys-libs/libsepol
+ x11-libs/pango
+??? pirut
+ x11-libs/libXt
+ >=sys-libs/slang-2.0.6
+ =dev-libs/glib-2*
+??? libdhcp
+ >=sys-apps/mkinitrd-5.1.2
+??? audit-libs
+ >=sys-apps/parted-1.7.1
+ >=dev-python/pyparted-1.7.2
+ app-admin/system-config-date
+ sys-fs/dosfstools
+??? pyblock
+??? libbdevid
+ dev-python/rhpxl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ for i in app-arch/rpm dev-libs/libxml2
+ if ! built_with_use $i python; then
+ local msg="Build $i with USE=python"
+ eerror "$msg"
+ die "$msg"
+ fi
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}