summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:03:36 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:03:36 +0100
commitf3109104b8c0b8827b33ccc040784f53336260fb (patch)
tree9a7d1650ffc331dc9b28a13f59ba2fb10b82f8b6 /app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild
parentdev-python/identify: superseded by gentoo repository (diff)
downloadeva-f3109104b8c0b8827b33ccc040784f53336260fb.tar.gz
eva-f3109104b8c0b8827b33ccc040784f53336260fb.tar.bz2
eva-f3109104b8c0b8827b33ccc040784f53336260fb.zip
app-backup/restic-rest-server: new package, add 0.12.1
Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild')
-rw-r--r--app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild b/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild
new file mode 100644
index 0000000..582359b
--- /dev/null
+++ b/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="high performance HTTP server that implements restic's REST backend API"
+HOMEPAGE="https://github.com/restic/rest-server"
+SRC_URI="https://github.com/restic/rest-server/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://www.whyte.ninja/pub/${P}-deps.tar.xz"
+S="${WORKDIR}/rest-server-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ local mygoargs=(
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ )
+
+ ego build "${mygoargs[@]}" -o rest-server ./cmd/rest-server
+}
+
+src_install() {
+ dobin rest-server
+ dodoc AUTHORS CHANGELOG.md README.md
+ # TODO: install systemd unit/socket
+}