summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-11-21 23:37:21 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2010-11-21 23:37:21 +0100
commit99686b536782ede4026d2d9176f7f5d6fcf8c78f (patch)
treeca9c80bfbf62a11c17efac2f52a48cf9d9615951 /media-sound
parentnet-libs/libdmapsharing: initial commit (diff)
downloadeva-99686b536782ede4026d2d9176f7f5d6fcf8c78f.tar.gz
eva-99686b536782ede4026d2d9176f7f5d6fcf8c78f.tar.bz2
eva-99686b536782ede4026d2d9176f7f5d6fcf8c78f.zip
media-sound/rhythmbox: initial commit
Add until libdmapsharing is moved to the tree (with soname fixes).
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/Manifest4
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.13.1.ebuild193
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.13.2.ebuild194
3 files changed, 391 insertions, 0 deletions
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
new file mode 100644
index 0000000..7e5d3d3
--- /dev/null
+++ b/media-sound/rhythmbox/Manifest
@@ -0,0 +1,4 @@
+DIST rhythmbox-0.13.1.tar.bz2 9787870 RMD160 14328a5deecad01842a15057ded28d6183f098b8 SHA1 104ddb341fe77ba260663d74a7f960634c30aa3c SHA256 98f9744cb80bca052f54a62bc965b134946ab6c2c107935b70de9d20c126cc7e
+DIST rhythmbox-0.13.2.tar.bz2 9936249 RMD160 b787b7c2ddbdce67e972a254aacdbc0c816f07e7 SHA1 7e7ea7dd6540842ee8e30dcb7f98e0d7aa6e6565 SHA256 f422e47d7e238ebe862650efbcb83672bca704df0a37c3391ad0e386c20b19e3
+EBUILD rhythmbox-0.13.1.ebuild 5042 RMD160 b36a8b21a3f7be7b633409caeb902fd9d8f9e88e SHA1 e172e36521306e47592e23a92987cf8eb9a62770 SHA256 bfb5f513003eb399dab7359c7fe7b7ccc78d4b0d48fe7684d3ca27eeacb7cbf6
+EBUILD rhythmbox-0.13.2.ebuild 5114 RMD160 7aa3d43438c36dbd05b6c1b424b2cf501eb0532f SHA1 807b6bc60d205cb1916c0e63466cce18a550594b SHA256 956b7d8876daa80d72c6229d01dfc372d3c958299e6ce30c215f8a1ccb5971ba
diff --git a/media-sound/rhythmbox/rhythmbox-0.13.1.ebuild b/media-sound/rhythmbox/rhythmbox-0.13.1.ebuild
new file mode 100644
index 0000000..a777b74
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.13.1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild,v 1.7 2010/09/25 18:42:27 armin76 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit eutils gnome2 python multilib virtualx
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="cdr daap doc gnome-keyring hal ipod libnotify lirc musicbrainz mtp nsplugin python test udev upnp webkit"
+
+# FIXME: double check what to do with fm-radio plugin
+# TODO: watchout for udev use flag changes
+COMMON_DEPEND=">=dev-libs/glib-2.26
+ dev-libs/libxml2
+ >=x11-libs/gtk+-2.20
+ >=dev-libs/dbus-glib-0.71
+ >=dev-libs/totem-pl-parser-2.28
+ >=gnome-base/gconf-2
+ >=gnome-extra/gnome-media-2.14
+ >=net-libs/libsoup-2.26:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+
+ >=media-libs/gst-plugins-base-0.10.20
+ || (
+ >=media-libs/gst-plugins-base-0.10.24
+ >=media-libs/gst-plugins-bad-0.10.6 )
+
+ app-misc/media-player-info
+
+ cdr? ( >=app-cdr/brasero-0.9.1 )
+ daap? (
+ >=net-libs/libdmapsharing-1.9:2.0
+ >=net-dns/avahi-0.6 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ udev? (
+ ipod? ( >=media-libs/libgpod-0.6 )
+ mtp? ( >=media-libs/libmtp-0.3 )
+ >=sys-fs/udev-145[extras] )
+ hal? (
+ ipod? ( >=media-libs/libgpod-0.6 )
+ mtp? ( >=media-libs/libmtp-0.3 )
+ >=sys-apps/hal-0.5 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ lirc? ( app-misc/lirc )
+ musicbrainz? ( media-libs/musicbrainz:3 )
+ python? (
+ || (
+ >=dev-lang/python-2.5
+ dev-python/celementtree )
+ >=dev-python/pygtk-2.8
+ >=dev-python/pygobject-2.15.4
+ >=dev-python/gconf-python-2.22
+ >=dev-python/libgnome-python-2.22
+ >=dev-python/gnome-keyring-python-2.22
+ >=dev-python/gst-python-0.10.8
+ webkit? (
+ dev-python/mako
+ dev-python/pywebkitgtk )
+ upnp? ( media-video/coherence )
+ )
+ webkit? ( >=net-libs/webkit-gtk-1.1.7 )
+ "
+
+RDEPEND="${COMMON_DEPEND}
+ >=media-plugins/gst-plugins-soup-0.10
+ >=media-plugins/gst-plugins-libmms-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10 )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-taglib-0.10.6
+ nsplugin? ( net-libs/xulrunner )"
+
+# gtk-doc-am needed for eautoreconf
+# dev-util/gtk-doc-am
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.9.1
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? ( dev-libs/check )"
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+
+pkg_setup() {
+ python_set_active_version 2
+ G2CONF="${G2CONF} PYTHON=$(PYTHON -2)"
+
+ if ! use hal && ! use udev; then
+ if use ipod; then
+ ewarn "ipod support requires hal or udev support. Please"
+ ewarn "re-emerge with USE=udev to enable ipod support"
+ G2CONF="${G2CONF} --without-ipod"
+ fi
+
+ if use mtp; then
+ ewarn "MTP support requires hal or udev support. Please"
+ ewarn "re-emerge with USE=udev to enable MTP support"
+ G2CONF="${G2CONF} --without-mtp"
+ fi
+ else
+ G2CONF="${G2CONF} $(use_with ipod) $(use_with mtp)"
+ fi
+
+ if use hal && use udev; then
+ einfo "udev support replaces hal support completely. You can disable"
+ einfo "hal on this package via /etc/portage/package.use."
+ fi
+
+ if ! use cdr ; then
+ ewarn "You have cdr USE flag disabled."
+ ewarn "You will not be able to burn CDs."
+ else
+ G2CONF="${G2CONF} $(use_with cdr libbrasero-media) --without-libnautilus-burn"
+ fi
+
+ if ! use python; then
+ if use upnp; then
+ ewarn "You need python support in addition to upnp"
+ fi
+ fi
+
+ G2CONF="${G2CONF}
+ MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins
+ $(use_with gnome-keyring)
+ $(use_with udev gudev)
+ $(use_with hal)
+ $(use_enable libnotify)
+ $(use_enable lirc)
+ $(use_enable musicbrainz)
+ $(use_enable nsplugin browser-plugin)
+ $(use_enable python)
+ $(use_enable daap)
+ $(use_with daap mdns avahi)
+ $(use_with webkit)
+ --enable-mmkeys
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-static
+ --disable-vala
+ GST_INSPECT=$(type -P true)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "test failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${ED}/usr/$(get_libdir)/rhythmbox/plugins" -name "*.la" -delete \
+ || die "failed to remove *.la files"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
+
+ ewarn
+ ewarn "If ${PN} doesn't play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
+}
diff --git a/media-sound/rhythmbox/rhythmbox-0.13.2.ebuild b/media-sound/rhythmbox/rhythmbox-0.13.2.ebuild
new file mode 100644
index 0000000..34cc3ff
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.13.2.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild,v 1.7 2010/09/25 18:42:27 armin76 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit eutils gnome2 python multilib virtualx
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="cdr daap doc gnome-keyring hal ipod +lastfm libnotify lirc musicbrainz mtp nsplugin python test udev upnp webkit"
+
+# FIXME: double check what to do with fm-radio plugin
+# TODO: watchout for udev use flag changes
+COMMON_DEPEND=">=dev-libs/glib-2.26
+ dev-libs/libxml2
+ >=x11-libs/gtk+-2.20
+ >=dev-libs/dbus-glib-0.71
+ >=dev-libs/totem-pl-parser-2.32.1
+ >=gnome-base/gconf-2
+ >=gnome-extra/gnome-media-2.14
+ >=net-libs/libsoup-2.26:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+
+ >=media-libs/gst-plugins-base-0.10.20
+ || (
+ >=media-libs/gst-plugins-base-0.10.24
+ >=media-libs/gst-plugins-bad-0.10.6 )
+
+ app-misc/media-player-info
+
+ cdr? ( >=app-cdr/brasero-0.9.1 )
+ daap? (
+ >=net-libs/libdmapsharing-2.1.6:2.2
+ >=net-dns/avahi-0.6 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ udev? (
+ ipod? ( >=media-libs/libgpod-0.7.92 )
+ mtp? ( >=media-libs/libmtp-0.3 )
+ >=sys-fs/udev-145[extras] )
+ hal? (
+ ipod? ( >=media-libs/libgpod-0.6 )
+ mtp? ( >=media-libs/libmtp-0.3 )
+ >=sys-apps/hal-0.5 )
+ lastfm? ( dev-libs/json-glib )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ lirc? ( app-misc/lirc )
+ musicbrainz? ( media-libs/musicbrainz:3 )
+ python? (
+ || (
+ >=dev-lang/python-2.5
+ dev-python/celementtree )
+ >=dev-python/pygtk-2.8:2
+ >=dev-python/pygobject-2.15.4:2
+ >=dev-python/gconf-python-2.22
+ >=dev-python/libgnome-python-2.22
+ >=dev-python/gnome-keyring-python-2.22
+ >=dev-python/gst-python-0.10.8
+ webkit? (
+ dev-python/mako
+ dev-python/pywebkitgtk )
+ upnp? ( media-video/coherence )
+ )
+ webkit? ( >=net-libs/webkit-gtk-1.1.7 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-plugins/gst-plugins-soup-0.10
+ >=media-plugins/gst-plugins-libmms-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10 )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-taglib-0.10.6
+ nsplugin? ( net-libs/xulrunner )
+"
+# gtk-doc-am needed for eautoreconf
+# dev-util/gtk-doc-am
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.9.1
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? ( dev-libs/check )"
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+
+pkg_setup() {
+ python_set_active_version 2
+ G2CONF="${G2CONF} PYTHON=$(PYTHON -2)"
+
+ if ! use hal && ! use udev; then
+ if use ipod; then
+ ewarn "ipod support requires hal or udev support. Please"
+ ewarn "re-emerge with USE=udev to enable ipod support"
+ G2CONF="${G2CONF} --without-ipod"
+ fi
+
+ if use mtp; then
+ ewarn "MTP support requires hal or udev support. Please"
+ ewarn "re-emerge with USE=udev to enable MTP support"
+ G2CONF="${G2CONF} --without-mtp"
+ fi
+ else
+ G2CONF="${G2CONF} $(use_with ipod) $(use_with mtp)"
+ fi
+
+ if use hal && use udev; then
+ einfo "udev support replaces hal support completely. You can disable"
+ einfo "hal on this package via /etc/portage/package.use."
+ fi
+
+ if ! use cdr ; then
+ ewarn "You have cdr USE flag disabled."
+ ewarn "You will not be able to burn CDs."
+ else
+ G2CONF="${G2CONF} $(use_with cdr libbrasero-media) --without-libnautilus-burn"
+ fi
+
+ if ! use python; then
+ if use upnp; then
+ ewarn "You need python support in addition to upnp"
+ fi
+ fi
+
+ G2CONF="${G2CONF}
+ MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins
+ $(use_with gnome-keyring)
+ $(use_with udev gudev)
+ $(use_with hal)
+ $(use_enable lastfm)
+ $(use_enable libnotify)
+ $(use_enable lirc)
+ $(use_enable musicbrainz)
+ $(use_enable nsplugin browser-plugin)
+ $(use_enable python)
+ $(use_enable daap)
+ $(use_with daap mdns avahi)
+ $(use_with webkit)
+ --enable-mmkeys
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-static
+ --disable-vala
+ GST_INSPECT=$(type -P true)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "test failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${ED}/usr/$(get_libdir)/rhythmbox/plugins" -name "*.la" -delete \
+ || die "failed to remove *.la files"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
+
+ ewarn
+ ewarn "If ${PN} doesn't play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
+}