summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.8.ebuild')
-rw-r--r--gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.8.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.8.ebuild b/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.8.ebuild
deleted file mode 100644
index c83aceb..0000000
--- a/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.8.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit autotools eutils gnome2
-
-MY_P=${P/_p/_}
-
-DESCRIPTION="Global menubar applet for Gnome2."
-HOMEPAGE="http://code.google.com/p/gnome2-globalmenu/"
-SRC_URI="http://gnome2-globalmenu.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gnome test xfce"
-
-RDEPEND=">=x11-libs/gtk+-2.10.0
- >=dev-libs/glib-2.10.0
- >=gnome-base/gconf-2
- >=x11-libs/libwnck-2.16.0
- >=gnome-base/gnome-menus-2.16.0
- gnome? (
- >=gnome-base/gnome-panel-2.16.0
- >=x11-libs/libnotify-0.4.4 )
- xfce? (
- >=xfce-base/xfce4-panel-4.4.3 )
- >=x11-libs/libX11-1.1.0"
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-util/pkgconfig
- >=dev-lang/vala-0.7.7"
-
-S="${WORKDIR}/${MY_P}"
-DOCS="AUTHORS ChangeLog NEWS README*"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --without-gir
- --docdir=/usr/share/doc/${PF}
- $(use_enable test tests)
- $(use_with gnome gnome-panel)
- $(use_with xfce xfce4-panel)"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Fix compilation problem with --as-needed
- epatch "${FILESDIR}/${PN}-0.7.7-as-needed.patch"
-
- intltoolize --force --copy --automake || die "intltoolize failed"
- AT_M4DIR="autotools" eautoreconf
-}