summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2022-10-18 07:30:08 +0200
committerHans de Graaff <hans@degraaff.org>2022-10-18 07:30:08 +0200
commit4a7cc6dec7192275c523a494c3aa30a8571016f5 (patch)
tree404d4c30acf0c64a45dcdae2103b354c70c79bd7 /dev-util
parentdev-ruby/rubocop-ast: add 1.22.0 (diff)
downloadgraaff-4a7cc6dec7192275c523a494c3aa30a8571016f5.tar.gz
graaff-4a7cc6dec7192275c523a494c3aa30a8571016f5.tar.bz2
graaff-4a7cc6dec7192275c523a494c3aa30a8571016f5.zip
dev-util/mdl: add 0.12.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mdl/Manifest1
-rw-r--r--dev-util/mdl/mdl-0.12.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/mdl/Manifest b/dev-util/mdl/Manifest
index 3102afce..fa1ac4e2 100644
--- a/dev-util/mdl/Manifest
+++ b/dev-util/mdl/Manifest
@@ -1 +1,2 @@
DIST mdl-0.11.0.tar.gz 58853 BLAKE2B cf2ce689f411f8bda3e2879a8a7a33235a35f449e686cddb1acd1a4100dbaec3ec96455140744291ee3a0e8df23a54b6fe841bb014df33bc268ac58585fb510a SHA512 2d7586fd9b9ec8eaeaf16a8bccfba7572090a14885188e5503a657353b3353d9350e02ac26186abda3691ec2c31efdacb11b3410bfcccf52e515b3484cdb4985
+DIST mdl-0.12.0.tar.gz 63127 BLAKE2B 9114b99c1cbb12250af682fa1431b8e01c45bc668916827214ab35c6f89dbb3e374798ef0a300f9979c89015ce277eb5f91f76fa471638fd126fcc1987070380 SHA512 9045ebf6fe2f1981f79f791d231f0aff1c952403575566ab454157e8181df799f6cbb1cc4e1611e58b0f656f8b37490e023affe5ef738168563f78e3a38ac607
diff --git a/dev-util/mdl/mdl-0.12.0.ebuild b/dev-util/mdl/mdl-0.12.0.ebuild
new file mode 100644
index 00000000..06a0fa96
--- /dev/null
+++ b/dev-util/mdl/mdl-0.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mdl.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Style checker/lint tool for markdown files"
+HOMEPAGE="https://github.com/markdownlint/markdownlint"
+SRC_URI="https://github.com/markdownlint/markdownlint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="markdownlint-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/kramdown-2.3:2
+ >=dev-ruby/kramdown-parser-gfm-1.1:1
+ >=dev-ruby/mixlib-cli-2.1.1:0
+ >=dev-ruby/mixlib-config-2.2.1:0
+ dev-ruby/mixlib-shellout
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/setup_tests.rb || die
+ sed -i -e '3igem "kramdown-parser-gfm", "~> 1.0"' test/setup_tests.rb || die
+
+ # Throws errors and probably needs a more elaborate environment setup
+ rm -f test/test_cli.rb || die
+}