summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2021-12-12 09:22:53 +0100
committerHans de Graaff <hans@degraaff.org>2021-12-12 09:22:53 +0100
commitae40478c63a27753eff9f4cab8116eddebc3cdd1 (patch)
tree0afde4503aef26240fc4c9304c298b1e5cf2f90f /www-apache
parentdev-libs/lasso: add 2.7.0 (diff)
downloadgraaff-ae40478c63a27753eff9f4cab8116eddebc3cdd1.tar.gz
graaff-ae40478c63a27753eff9f4cab8116eddebc3cdd1.tar.bz2
graaff-ae40478c63a27753eff9f4cab8116eddebc3cdd1.zip
www-apache/mod_auth_mellon: add 0.18.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_mellon/Manifest1
-rw-r--r--www-apache/mod_auth_mellon/mod_auth_mellon-0.18.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_auth_mellon/Manifest b/www-apache/mod_auth_mellon/Manifest
index af03d982..6d95a3dc 100644
--- a/www-apache/mod_auth_mellon/Manifest
+++ b/www-apache/mod_auth_mellon/Manifest
@@ -1 +1,2 @@
+DIST v0.18.0.tar.gz 918471 BLAKE2B 71d2e847f35c9d1f192df2d4a378e5f0fa9d219f7190f083ec27114df6a821892296051608e06fa766e19991bb50fa0816d1cb62beb72035ad675c9667a72045 SHA512 477ac302fda9ed33b2ca51e88379250a41cc85111e71cacc8ba9f16cd8a2b63af6393fb038fc8f5c211b97926ef368c5989c92570c2e3c9eae072c7b4d32d7d5
DIST v0_16_0.tar.gz 916782 BLAKE2B 9e16e7a272a04a599e4159a0eace8be7a814e57fd85415bec188bba58c870ec1799590def09ae5a29a9c763bd79ebecaaee9c5cc37caa8e7ce6e6ce2b8bceb56 SHA512 9d914185c53a4ae9da200a99bfa2427db45e5c8d2788f41e92032211407a12d516d5b45658a79a7969867df72d8abb2aa1392c74c0d9af5063e2b30163ccdc32
diff --git a/www-apache/mod_auth_mellon/mod_auth_mellon-0.18.0.ebuild b/www-apache/mod_auth_mellon/mod_auth_mellon-0.18.0.ebuild
new file mode 100644
index 00000000..dda5f1c8
--- /dev/null
+++ b/www-apache/mod_auth_mellon/mod_auth_mellon-0.18.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools apache-module
+
+SRC_URI="https://github.com/latchset/mod_auth_mellon/archive/v${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="An Apache module with a simple SAML 2.0 service provider"
+HOMEPAGE="https://github.com/latchset/mod_auth_mellon"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="diagnostics"
+need_apache2_4
+
+CDEPEND=">=dev-libs/lasso-2.1 net-misc/curl dev-libs/openssl:0= "
+DEPEND+=" virtual/pkgconfig ${CDEPEND}"
+RDEPEND=${CDEPEND}
+
+DOCFILES="ECP.rst NEWS README.md"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_MELLON"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
+src_prepare() {
+ eapply_user
+
+ eautoreconf
+
+ econf $(use_enable diagnostics)
+}
+
+src_compile() {
+ # Use -j1 to ensure that the apxs step is run first
+ emake -j1
+}
+
+src_install() {
+ apache-module_src_install
+
+ newbin mellon_create_metadata.sh mellon_create_metadata
+}