summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lunit/lunit-0.4.ebuild')
-rw-r--r--dev-lua/lunit/lunit-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lua/lunit/lunit-0.4.ebuild b/dev-lua/lunit/lunit-0.4.ebuild
new file mode 100644
index 0000000..933fb54
--- /dev/null
+++ b/dev-lua/lunit/lunit-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit lua
+
+DESCRIPTION="A unit testing framework for Lua"
+HOMEPAGE="http://www.mroth.net/lunit/"
+SRC_URI="http://www.mroth.net/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ lua_install_module lunit.lua lunit-console.lua
+ dobin lunit || die "dobin failed"
+ dodoc ANNOUNCE CHANGES DOCUMENTATION README* example.lua || die "dodoc failed"
+}
+
+src_test() {
+ ./lunit lunit-tests.lua || die "tests failed"
+}