summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.7.1-r1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-devel/llvm/llvm-3.7.1-r1.ebuild b/sys-devel/llvm/llvm-3.7.1-r1.ebuild
index 7bd5432..58b7c72 100644
--- a/sys-devel/llvm/llvm-3.7.1-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
PYTHON_COMPAT=( python2_7 )
-inherit check-reqs cmake-utils eutils flag-o-matic multilib \
+inherit check-reqs cmake-utils eutils flag-o-matic multilib linux-info \
multilib-minimal python-single-r1 toolchain-funcs pax-utils prefix
DESCRIPTION="Low Level Virtual Machine"
@@ -24,7 +24,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="clang debug doc gold libedit +libffi lldb multitarget ncurses ocaml
python +static-analyzer test xml video_cards_radeon
- kernel_Darwin kernel_FreeBSD"
+ kernel_Darwin kernel_FreeBSD rap"
COMMON_DEPEND="
sys-libs/zlib:0=
@@ -232,6 +232,13 @@ src_prepare() {
# User patches
eapply_user
+ if kernel_is -lt 2 6 32; then
+ # on RHEL5, linux/perf_event.h (needing kernel >=2.6.32) is not available.
+ # https://llvm.org/bugs/show_bug.cgi?id=17901
+ elog "Removing compiler-rt on <linux-2.6.32..."
+ rm -r projects/compiler-rt || die "Removing compiler-rt failed."
+ fi
+
python_setup
# Native libdir is used to hold LLVMgold.so
@@ -278,6 +285,8 @@ multilib_src_configure() {
-DHAVE_HISTEDIT_H=$(usex libedit)
)
+ use rap && mycmakeargs+=( -DDEFAULT_SYSROOT="${EPREFIX}" )
+
if use clang; then
mycmakeargs+=(
-DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
@@ -528,9 +537,6 @@ multilib_src_install_all() {
popd >/dev/null || die
fi
- # AddressSanitizer symbolizer (currently separate)
- dobin "${S}"/projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
-
popd >/dev/null || die
python_fix_shebang "${ED}"