summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/heirloom-sh/heirloom-sh-050706.ebuild')
-rw-r--r--app-shells/heirloom-sh/heirloom-sh-050706.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/heirloom-sh/heirloom-sh-050706.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706.ebuild
new file mode 100644
index 0000000..d1844be
--- /dev/null
+++ b/app-shells/heirloom-sh/heirloom-sh-050706.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Solaris-sh based Bourne Shell, installed as 'jsh'."
+HOMEPAGE="http://foo.bar.com/"
+
+SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"
+
+LICENSE="CDDL"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE="+spell"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -f makefile \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ CPPFLAGS="-D_GNU_SOURCE" \
+ LARGEF="-D_FILE_OFFSET_BITS=64" \
+ SPELL="$(use spell&&echo '-DSPELL')" \
+ sh sh.1.out || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe sh jsh
+ newman sh.1.out jsh.1
+ dodoc CHANGES README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "${P} has been installed as /bin/jsh. If you want to use ${PN} as your /bin/sh, do:"
+ elog "ln -sf jsh /bin/sh"
+}