summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-09-04 00:40:25 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-09-04 00:40:25 +0000
commitc57b4593ebcf4d82172d04a9d962b1d490fa3e21 (patch)
tree5927cb42040d558cf64bbd028ca0ca88c3c4924e /sys-kernel
parentmake sure bfd regenerates its headers (diff)
downloadlu_zero-c57b4593ebcf4d82172d04a9d962b1d490fa3e21.tar.gz
lu_zero-c57b4593ebcf4d82172d04a9d962b1d490fa3e21.tar.bz2
lu_zero-c57b4593ebcf4d82172d04a9d962b1d490fa3e21.zip
linux headers fixed in portage
svn path=/; revision=57
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.16-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.16-r1.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.16-r1.ebuild
deleted file mode 100644
index 2e978d8..0000000
--- a/sys-kernel/linux-headers/linux-headers-2.6.16-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.16.ebuild,v 1.2 2006/04/18 15:39:32 plasmaroo Exp $
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
-inherit eutils kernel-2 multilib
-detect_version
-
-PATCHES_V='2'
-
-SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.11-m68k-headers.patch.bz2
- http://dev.gentoo.org/~plasmaroo/patches/kernel/gentoo-headers/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
-KEYWORDS="-*"
-
-DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
- sparc? ( gcc64? ( sys-devel/gcc-sparc64 ) )"
-
-UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
-
-wrap_headers_fix() {
- for i in $*
- do
- echo -n " $1/"
- cd ${S}/include/$1
- headers___fix $(find . -type f -print)
- shift
- done
- echo
-}
-
-src_unpack() {
- ABI=${KERNEL_ABI}
- kernel-2_src_unpack
-
- # This should always be used but it has a bunch of hunks which
- # apply to include/linux/ which i'm unsure of so only use with
- # m68k for now (dont want to break other arches)
- [[ $(tc-arch) == "m68k" ]] && epatch "${DISTDIR}"/linux-2.6.11-m68k-headers.patch.bz2
-
- # Get headers to bootstrap on PPC
- if use ppc; then
- K_DEFCONFIG=pmac32_defconfig
- fi
- if use ppc64; then
- K_DEFCONFIG=ppc64_defconfig
- fi
-
- # Fixes ... all the wrapper magic is to keep sed from dumping
- # ugly warnings about how it can't work on a directory.
- cd "${S}"/include
- einfo "Applying automated fixes:"
- wrap_headers_fix asm-* linux
- einfo "... done"
-}