summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild b/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
index 57f0c4c..011f04d 100644
--- a/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
@@ -42,11 +42,18 @@ src_prepare() {
# Fix infinite loop while processing po/Makefile.in
eautoreconf
}
-
src_configure() {
econf $(use_enable glitz) $(use_enable xcomposite xextend)
}
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}
+pkg_postinst() {
+ elog "Cairo-Dock is an app that draws on a RGBA GLX visual."
+ elog "Some users have noticed that if the dock is launched,"
+ elog "severals qt4-based applications could crash, like skype or vlc."
+ elog "If you have this problem, add the following line into your bashrc :"
+ echo
+ elog "alias vlc='export XLIB_SKIP_ARGB_VISUALS=1; vlc; unset XLIB_SKIP_ARGB_VISUALS'"
+ elog "see http://www.qtforum.org/article/26669/qt4-mess-up-the-opengl-context.html for more details."
+}