summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-21 23:15:58 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-21 23:15:58 +0000
commitb4dbe2d5a54d7c8a9d17322bdb0d7fcf610ba1b9 (patch)
tree8a6cd93ec6eabb91dbaa799c7d99b424acddfb71
parentUpdated ebuild, adding the exec-stack fixes from #153382 (thanks to nattfodd ... (diff)
downloadphreak-b4dbe2d5a54d7c8a9d17322bdb0d7fcf610ba1b9.tar.gz
phreak-b4dbe2d5a54d7c8a9d17322bdb0d7fcf610ba1b9.tar.bz2
phreak-b4dbe2d5a54d7c8a9d17322bdb0d7fcf610ba1b9.zip
Some comment fixes, reordering the installphase.
svn path=/; revision=315
-rw-r--r--hardened/dev-lang/ocaml/Manifest8
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild36
2 files changed, 21 insertions, 23 deletions
diff --git a/hardened/dev-lang/ocaml/Manifest b/hardened/dev-lang/ocaml/Manifest
index 2e24305..d90b75c 100644
--- a/hardened/dev-lang/ocaml/Manifest
+++ b/hardened/dev-lang/ocaml/Manifest
@@ -19,10 +19,10 @@ MD5 bcc5109143faee7e7b8f7f76bd4726a7 files/ocaml-rebuild.sh 1361
RMD160 a9c452fbea18de3b38d8240f887f8595e529643e files/ocaml-rebuild.sh 1361
SHA256 a8004cd4bca96ab3fc595fcfd7dbe88903833f9e430149c3d04c9fda84362b64 files/ocaml-rebuild.sh 1361
DIST ocaml-3.09.3.tar.bz2 2038617 RMD160 fdc124218c556c62c897ee6720970279e2d5426b SHA1 5d63c6e0d13463f85c0d5147d641d2bceef87d6b SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f
-EBUILD ocaml-3.09.3-r1.ebuild 3462 RMD160 4952a9111303f85311d0df086a6c523e0ef6d9cd SHA1 1eb8ad81c7e5a286dec3b4e2bd34cf4748d9e3c0 SHA256 5fc59112a58a2e41a955bf202c83b10e7d60e3dc23523fc146cc507702935f18
-MD5 4e63de02dcf832096cbcb186758b53c3 ocaml-3.09.3-r1.ebuild 3462
-RMD160 4952a9111303f85311d0df086a6c523e0ef6d9cd ocaml-3.09.3-r1.ebuild 3462
-SHA256 5fc59112a58a2e41a955bf202c83b10e7d60e3dc23523fc146cc507702935f18 ocaml-3.09.3-r1.ebuild 3462
+EBUILD ocaml-3.09.3-r1.ebuild 3700 RMD160 b72b6e841d328e379177ad93af7f888ef202d56d SHA1 6e57a8334bcb14a423a76b04a712df583a9f2c12 SHA256 9871cc7dac8418bc29967087508a90fc3af9bd75418698b4b63c7c13aeee7135
+MD5 19cd406bf5ed267f40816a6d3b441afe ocaml-3.09.3-r1.ebuild 3700
+RMD160 b72b6e841d328e379177ad93af7f888ef202d56d ocaml-3.09.3-r1.ebuild 3700
+SHA256 9871cc7dac8418bc29967087508a90fc3af9bd75418698b4b63c7c13aeee7135 ocaml-3.09.3-r1.ebuild 3700
MD5 71f3dc5bc2ee57a403689b56bc1a85c1 files/digest-ocaml-3.09.3-r1 244
RMD160 e7f0898889b94faae3b1481555bac42e9298b370 files/digest-ocaml-3.09.3-r1 244
SHA256 19708f759185ed39623e03921462ba20fb6f3533268673d2bcd7dd07cef57350 files/digest-ocaml-3.09.3-r1 244
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index 08b84eb..aeacb75 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-3.09/${P}.tar.bz2"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="amd64 ppc ppc64 sparc x86 x86-fbsd"
IUSE="tk latex"
DEPEND="virtual/libc
@@ -45,32 +45,30 @@ src_unpack() {
}
src_compile() {
+ local myconf="--host ${CHOST}"
+ # Maybe we should use strip-flags instead ?
elog
- elog "Building ocaml with unsafe CFLAGS can have unexpected results."
+ elog "Building ${CATEGORY}/${PN} with unsafe CFLAGS can have unexpected results."
elog "Please retry building with safer CFLAGS before reporting bugs!"
elog
replace-flags "-O?" -O2
- local myconf
use tk || myconf="-no-tk"
- # Fix for kernel_arch != system_ach (bug #135641)
- myconf="${myconf} -host ${CHOST}"
-
# ocaml uses a home-brewn configure script, preventing it to use econf.
./configure -prefix /usr \
--bindir /usr/bin \
--libdir /usr/$(get_libdir)/ocaml \
--mandir /usr/share/man \
- --with-pthread ${myconf} || die
+ --with-pthread ${myconf} || die "configure failed!"
- make world || die
+ make world || die "make world failed!"
- # Native code generation unsupported on some archs
+ # Native code generation is unsupported on some archs
if ! use ppc64 ; then
- make opt || die
- make opt.opt || die
+ make opt || die "make opt failed!"
+ make opt.opt || die "make opt.opt failed!"
fi
}
@@ -82,25 +80,25 @@ src_install() {
make BINDIR=${D}/usr/bin \
LIBDIR=${D}/usr/$(get_libdir)/ocaml \
MANDIR=${D}/usr/share/man \
- install || die
-
- # Pax-mark the ocaml compilers, since they are trying to rewrite the segment.
- pax-mark -m "${D}"/usr/bin/*.opt
+ install || die "make install failed!"
- # compiler libs
+ # Install the compiler libs
dodir /usr/$(get_libdir)/ocaml/compiler-libs
insinto /usr/$(get_libdir)/ocaml/compiler-libs
doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
- # headers
+ # Symlink the headers to the right place
dodir /usr/include
dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
- # silly, silly makefiles
+ # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
- # documentation
dodoc Changes INSTALL LICENSE README Upgrading
+
+ # Pax-mark the ocaml compilers, since they are trying to rewrite the segment
+ # (which will obviously fail on systems which are PAX_MPROTECT enabled).
+ pax-mark -m "${D}"/usr/bin/*.opt
}
pkg_postinst() {