summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-08-23 19:08:24 +0000
committerChristian Heim <phreak@gentoo.org>2007-08-23 19:08:24 +0000
commit77410c4a0c1b314056549ed41fadb8cad45a0f8b (patch)
tree9edd58a6105a6bcbbef3cea8364049ac5c822af2 /private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild
parentFixing the manifest. (diff)
downloadphreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.tar.gz
phreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.tar.bz2
phreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.zip
Add app-arch/apt and app-arch/reprepro to my repository.
svn path=/; revision=361
Diffstat (limited to 'private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild')
-rw-r--r--private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild b/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild
new file mode 100644
index 0000000..422559c
--- /dev/null
+++ b/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION=""
+HOMEPAGE=""
+SRC_URI="mirror://debian/pool/main/r/reprepro/reprepro_${PV}.orig.tar.gz"
+
+LICENSE="GPL-v2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="bzip2"
+
+DEPEND="app-crypt/gnupg
+ ~sys-libs/db-4.5
+ app-arch/libarchive
+ bzip2? ( app-arch/bzip2 )
+ app-crypt/gpgme"
+RDEPEND="${DEPEND}
+ app-arch/apt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-db4.5.patch
+ epatch "${FILESDIR}"/${P}-gpgme.patch
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+
+ econf \
+ --with-libdb=4.5 \
+ --with-gpgme=/usr/include/gpgme || die "econf failed!"
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+ dodoc ChangeLog TODO README NEWS
+}