summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild b/net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild
index f6d8eea..22b3d1a 100644
--- a/net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild
+++ b/net-analyzer/wireshark/wireshark-0.99.7_rc2.ebuild
@@ -129,28 +129,30 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ for file in /usr/bin/tshark /usr/bin/dumpcap
+ do
+ fowners 0:wireshark ${file}
+ fperms 6550 ${file}
+ done
+
insinto /usr/include/wiretap
doins wiretap/wtap.h
dodoc AUTHORS ChangeLog NEWS README*
- for file in /usr/bin/tshark /usr/bin/dumpcap
- do
- fowners 0:wireshark "${D}"${file}
- fperms 6550 "${D}"${file}
- done
-
if use gtk ; then
insinto /usr/share/icons/hicolor/16x16/apps
- newins "${S}"/image/hi16-app-wireshark.png wireshark.png
+ newins image/hi16-app-wireshark.png wireshark.png
insinto /usr/share/icons/hicolor/32x32/apps
- newins "${S}"/image/hi32-app-wireshark.png wireshark.png
+ newins image/hi32-app-wireshark.png wireshark.png
insinto /usr/share/icons/hicolor/48x48/apps
- newins "${S}"/image/hi48-app-wireshark.png wireshark.png
- #make_desktop_entry wireshark "Wireshark" wireshark
+ newins image/hi48-app-wireshark.png wireshark.png
+ insinto /usr/share/applications
+ # Wireshark should not be ran as root in KDE.
+ # Bug: http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=2127
+ sed -i '/X-KDE-SubstituteUID/d' wireshark.desktop
+ doins wireshark.desktop
fi
- #dosym tshark /usr/bin/tethereal
- #use gtk && dosym wireshark /usr/bin/ethereal
}
pkg_postinst() {