summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <roy@marples.name>2008-03-25 14:09:14 +0000
committerRoy Marples <roy@marples.name>2008-03-25 14:09:14 +0000
commit4532e4b36505c12da335fe0bedaa73d46e431049 (patch)
tree6c45cfe6aa5f2e059295c40a095d6d6fbf585b4b
parentPrefer static over PAM, as PAM is only used by s-s-d and only for pam_limits.so. (diff)
downloaduberlord-4532e4b36505c12da335fe0bedaa73d46e431049.tar.gz
uberlord-4532e4b36505c12da335fe0bedaa73d46e431049.tar.bz2
uberlord-4532e4b36505c12da335fe0bedaa73d46e431049.zip
Remove baselayout ebuild.
-rw-r--r--sys-apps/baselayout/Manifest2
-rw-r--r--sys-apps/baselayout/baselayout-2.0.0.ebuild110
2 files changed, 0 insertions, 112 deletions
diff --git a/sys-apps/baselayout/Manifest b/sys-apps/baselayout/Manifest
deleted file mode 100644
index 2be0946..0000000
--- a/sys-apps/baselayout/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST baselayout-2.0.0.tar.bz2 29045 RMD160 191c772d57a4e7cea1dee1e0eb2b093c6463ecb9 SHA1 7eeecd6723a55559bbf9767ad7701956290e5340 SHA256 907841ffe8ed45d6de54c955b6a783f35bae4b655332779b65a55ef249c36689
-EBUILD baselayout-2.0.0.ebuild 4042 RMD160 48e5f11a5a21a817deeef7a4631bbf4792890ada SHA1 067265f6974ac66620ce2822528b1727cfb445cb SHA256 061dd8c50e50e0326115f4aedfad5f7813d898348e65feed1d22d6f563e0b86f
diff --git a/sys-apps/baselayout/baselayout-2.0.0.ebuild b/sys-apps/baselayout/baselayout-2.0.0.ebuild
deleted file mode 100644
index 831bbd2..0000000
--- a/sys-apps/baselayout/baselayout-2.0.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Filesystem baselayout and init scripts"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI="http://roy.marples.name/~roy/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bootstrap build kernel_linux kernel_FreeBSD"
-
-PDEPEND="sys-apps/openrc"
-RDEPEND="!<net-misc/dhcpcd-2.0.0
- !<sys-apps/baselayout-2.0.0"
-DEPEND="virtual/os-headers"
-PROVIDE="virtual/baselayout"
-
-make_opts() {
- local libdir="lib"
- [ "${SYMLINK_LIB}" = "yes" ] && libdir=$(get_abi_LIBDIR "${DEFAULT_ABI}")
- echo "LIB=${libdir}"
-}
-
-pkg_preinst() {
- # We need to install directories and maybe some dev nodes when building
- # stages, but they cannot be in CONTENTS.
- # Also, we cannot reference $S as binpkg will break so we do this.
- if use build || use bootstrap ; then
- local libdirs="$(get_all_libdirs)" dir=
- # Create our multilib dirs - the Makefile has no knowledge of this
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
- for dir in ${libdirs}; do
- mkdir -p "${ROOT}${dir}"
- touch "${ROOT}${dir}"/.keep
- mkdir -p "${ROOT}usr/${dir}"
- touch "${ROOT}usr/${dir}"/.keep
- mkdir -p "${ROOT}usr/local/${dir}"
- touch "${ROOT}usr/local/${dir}"/.keep
- done
-
- # Ugly compatibility with stupid ebuilds and old profiles symlinks
- if [ "${SYMLINK_LIB}" = "yes" ] ; then
- rm -r "${ROOT}"/{lib,usr/lib,usr/local/lib} 2>/dev/null
- local lib=$(get_abi_LIBDIR ${DEFAULT_ABI})
- ln -s "${lib}" "${ROOT}lib"
- ln -s "${lib}" "${ROOT}usr/lib"
- ln -s "${lib}" "${ROOT}usr/local/lib"
- fi
-
- emake -C "${T}" $(make_opts) DESTDIR="${ROOT}" layout || die "failed to layout filesystem"
- fi
-}
-
-src_install() {
- emake $(make_opts) DESTDIR="${D}" install || die
- dodoc ChangeLog COPYRIGHT
-
- # Should this belong in another ebuild? Like say binutils?
- # List all the multilib libdirs in /etc/env/04multilib (only if they're
- # actually different from the normal
- if has_multilib_profile || [ $(get_libdir) != "lib" -o -n "${CONF_MULTILIBDIR}" ]; then
- local libdirs="$(get_all_libdirs)" libdirs_env= dir=
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
- for dir in ${libdirs}; do
- libdirs_env=${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}
- done
-
- # Special-case uglyness... For people updating from lib32 -> lib amd64
- # profiles, keep lib32 in the search path while it's around
- if has_multilib_profile && [ -d "${ROOT}"lib32 -o -d "${ROOT}"lib32 ] && ! hasq lib32 ${libdirs}; then
- libdirs_env="${libdirs_env}:/lib32:/usr/lib32:/usr/local/lib32"
- fi
- echo "LDPATH=\"${libdirs_env}\"" > "${T}"/04multilib
- doenvd "${T}"/04multilib
- fi
-
- # version for testing of features that *should* be present
- echo "Gentoo Base System release ${PV}" > "${D}"/etc/gentoo-release
-}
-
-pkg_postinst() {
- # We installed some files to /usr/share/baselayout instead of /etc to stop
- # (1) overwriting the user's settings
- # (2) screwing things up when attempting to merge files
- # (3) accidentally packaging up personal files with quickpkg
- # If they don't exist then we install them
- for x in master.passwd passwd shadow group fstab ; do
- [ -e "${ROOT}etc/${x}" ] && continue
- [ -e "${ROOT}usr/share/baselayout/${x}" ] || continue
- cp -p "${ROOT}usr/share/baselayout/${x}" "${ROOT}"etc
- done
-
- # This is also written in src_install (so it's in CONTENTS), but
- # write it here so that the new version is immediately in the file
- # (without waiting for the user to do etc-update)
- rm -f "${ROOT}"/etc/._cfg????_gentoo-release
- local release="${PV}"
- [ "${PR}" != r0 ] && release="${release}-${PR}"
- echo "Gentoo Base System release ${release}" > "${ROOT}"/etc/gentoo-release
-
- # whine about users that lack passwords #193541
- if [ -e "${ROOT}"/etc/shadow ]; then
- local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${ROOT}"/etc/shadow)
- if [ -n "${bad_users}" ] ; then
- echo
- ewarn "The following users lack passwords!"
- ewarn ${bad_users}
- fi
- fi
-}