summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <roy@marples.name>2007-12-28 12:10:49 +0000
committerRoy Marples <roy@marples.name>2007-12-28 12:10:49 +0000
commit5c2939b6f05a389e550d54f607cad0741ed0ccfc (patch)
treed96f08e924f9bd9e4326368f80f7eb696e665cd6
parentAs bootmisc init script has been split out, we need to transparently add swap... (diff)
downloaduberlord-5c2939b6f05a389e550d54f607cad0741ed0ccfc.tar.gz
uberlord-5c2939b6f05a389e550d54f607cad0741ed0ccfc.tar.bz2
uberlord-5c2939b6f05a389e550d54f607cad0741ed0ccfc.zip
Fix upgraders
-rw-r--r--sys-apps/openrc/openrc-0.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/openrc/openrc-0.1.ebuild b/sys-apps/openrc/openrc-0.1.ebuild
index b436d73..4452782 100644
--- a/sys-apps/openrc/openrc-0.1.ebuild
+++ b/sys-apps/openrc/openrc-0.1.ebuild
@@ -63,13 +63,15 @@ src_install() {
}
pkg_preinst() {
- local x=
-
# baselayout bootmisc init script has been split out in OpenRC
# so handle upgraders
if ! has_version sys-apps/openrc; then
- for x in procfs swap sysctl; do
- ln -s ../../init.d/"${x}" "${ROOT}"etc/runlevels/boot/"${x}"
+ local x= xtra=
+ use kernel_linux && xtra="${xtra} procfs sysctl"
+ use kernel_FreeBSD && xtra="${xtra} savecore dumpon"
+ for x in swap ${xtra}; do
+ [ -e "${ROOT}"etc/runlevels/boot/"${x}" ] && continue
+ ln -snf /etc/init.d/"${x}" "${ROOT}"etc/runlevels/boot/"${x}"
done
fi
}