summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/d2x-rebirth/d2x-rebirth-0.52.ebuild')
-rw-r--r--games-action/d2x-rebirth/d2x-rebirth-0.52.ebuild116
1 files changed, 0 insertions, 116 deletions
diff --git a/games-action/d2x-rebirth/d2x-rebirth-0.52.ebuild b/games-action/d2x-rebirth/d2x-rebirth-0.52.ebuild
deleted file mode 100644
index c655eda..0000000
--- a/games-action/d2x-rebirth/d2x-rebirth-0.52.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils games
-
-# DV is the Descent version. Used because the d1x-rebirth ebuild is similar.
-DV="2"
-DATE="20070505"
-DVX=d${DV}x
-FILE_START="${PN}_v${PV}-src-${DATE}"
-SRC_STEM="http://www.dxx-rebirth.de/download/dxx"
-
-DESCRIPTION="Descent Rebirth - enhanced Descent 2 engine"
-HOMEPAGE="http://www.dxx-rebirth.de/"
-SRC_URI="${SRC_STEM}/oss/src/${FILE_START}.tar.gz
- ${SRC_STEM}/res/dxx-rebirth_icons.zip"
-
-# Licence info at bug #117344. All 3 licences apply.
-LICENSE="D1X
- GPL-2
- as-is"
-SLOT="0"
-# Should work on amd64 also
-KEYWORDS="~x86"
-# mixer might segfault
-IUSE="awe32 debug mixer mpu401 opengl"
-
-QA_EXECSTACK="${GAMES_BINDIR:1}/${PN}"
-
-UIRDEPEND="media-libs/alsa-lib
- media-libs/libpng
- >=media-libs/libsdl-1.2.9
- >=media-libs/sdl-image-1.2.3-r1
- >=dev-games/physfs-1.0.1
- mixer? ( media-libs/sdl-mixer )
- opengl? (
- virtual/glu
- virtual/opengl )
- x11-libs/libX11
- x11-libs/libXext"
-UIDEPEND="x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto"
-# Does not work with the demo data
-RDEPEND="${UIRDEPEND}
- games-action/descent2-data"
-# demo? ( games-action/descent2-demodata )
-DEPEND="${UIRDEPEND}
- ${UIDEPEND}
- dev-util/scons
- app-arch/unzip"
-
-S=${WORKDIR}/${PN}
-dir=${GAMES_DATADIR}/${DVX}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix sandbox violation
- sed -i \
- -e "/ENV = os.environ)/a\env.SConsignFile()" \
- SConstruct || die "sed SConstruct"
-
- # Midi music - awe32 for most SoundBlaster cards
- if use awe32 ; then
- sed -i \
- -e "s:#define WANT_AWE32 0:#define WANT_AWE32 1:" \
- arch/linux/hmiplay.c || die "sed awe32"
- elif use mpu401 ; then
- sed -i \
- -e "s://#define WANT_MPU401 1:#define WANT_MPU401 1:" \
- arch/linux/hmiplay.c || die "sed mpu401"
- fi
-}
-
-src_compile() {
- # Assembler doesn't compile with sdl_only=1 - is best avoided totally
- local opts="no_asm=1"
-
- use debug && opts="${opts} debug=1"
- use mixer && opts="${opts} sdlmixer=1"
- use opengl || opts="${opts} sdl_only=1"
-
- # From "scons -h"
- scons \
- ${opts} \
- sharepath="${dir}" \
- || die "scons"
-}
-
-src_install() {
- local icon="${PN}.xpm"
- # Reasonable set of default options. Don't bother with ${DVX}.ini file.
- local params="-gl_trilinear -gl_anisotropy 8.0 -gl_transparency -gl_reticle 2 -fullscreen -menu_gameres -persistentdebris"
-
- local exe=${PN}-sdl
- use opengl && exe=${PN}-gl
-
- newgamesbin ${exe} ${PN} || die "newgamesbin ${exe}"
- games_make_wrapper ${PN}-common "${PN} ${params}"
- doicon "${WORKDIR}/${icon}" || die "doicon"
- make_desktop_entry ${PN}-common "Descent ${DV} Rebirth" "${icon}"
-
- dodoc *.txt "${WORKDIR}"/*.txt
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- elog "To play the game with common options, run: ${PN}-common"
- echo
-}