summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/delicious/delicious-20051023.ebuild')
-rw-r--r--app-emacs/delicious/delicious-20051023.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-emacs/delicious/delicious-20051023.ebuild b/app-emacs/delicious/delicious-20051023.ebuild
deleted file mode 100644
index d0f642c..0000000
--- a/app-emacs/delicious/delicious-20051023.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit elisp
-
-DESCRIPTION="Emacs client API for del.icio.us"
-HOMEPAGE="http://www.wjsullivan.net/delicious-el.html"
-SRC_URI="http://www.gunnarwrobel.de/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-IUSE="planner"
-KEYWORDS="~x86"
-
-SLOT="0"
-
-DEPEND="app-editors/emacs-cvs
- planner? ( app-emacs/planner
- app-emacs/muse )"
-
-SITEFILE=50delicious-gentoo.el
-
-S="${WORKDIR}/${PN}-el"
-
-src_compile() {
-
- cd ${S}
-
- local LOADPATH="/usr/share/emacs/22.0.50/lisp"
- LOADPATH="${LOADPATH}:${S}"
-
- if use planner; then
- LOADPATH="${LOADPATH}:/usr/share/emacs/site-lisp/planner"
- LOADPATH="${LOADPATH}:/usr/share/emacs/site-lisp/muse"
- fi
-
- local FILES="delicioapi.el delicious.el"
- use planner && FILES="${FILES} planner-delicious.el"
-
- EMACSLOADPATH="${LOADPATH}" elisp-compile ${FILES} || die
-}
-
-src_install() {
-
- cd ${S}
-
- dodoc README
-
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
-}
-
-pkg_postinst() {
- elisp-site-regen
-}
-
-pkg_postrm() {
- elisp-site-regen
-}