summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hub/hub-1.10.2.ebuild')
-rw-r--r--dev-vcs/hub/hub-1.10.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-vcs/hub/hub-1.10.2.ebuild b/dev-vcs/hub/hub-1.10.2.ebuild
deleted file mode 100644
index 910a7b0..0000000
--- a/dev-vcs/hub/hub-1.10.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Wrapper for git that makes working with GitHub easier"
-HOMEPAGE="http://defunkt.io/hub"
-SRC_URI="https://github.com/defunkt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-vcs/git-1.7.3"
-RDEPEND="${DEPEND}"
-
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/webmock
- )"
-
-# There are optional cucumber tests that require
-# dev-ruby/json
-# dev-ruby/sinatra
-# dev-util/aruba
-# but lots of them fails. Disabled for now.
-# use RUBY_FAKEGEM_TASK_TEST="test features" to enable them
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/${PN}.1
-}