aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2014-04-08 10:59:43 +0100
committerNick Clifton <nickc@redhat.com>2014-04-08 10:59:43 +0100
commit61e2488cd8497d158303a78563ad40f51f5c3f8e (patch)
tree096a515807bb59268398b4dd879929e93f78fec3 /bfd/libpei.h
parent[testsuite] Disable Ctrl-V use for mingw hosts. (diff)
downloadbinutils-gdb-61e2488cd8497d158303a78563ad40f51f5c3f8e.tar.gz
binutils-gdb-61e2488cd8497d158303a78563ad40f51f5c3f8e.tar.bz2
binutils-gdb-61e2488cd8497d158303a78563ad40f51f5c3f8e.zip
Add support for generating and inserting build IDs into COFF binaries.
* peXXigen.c (pe_print_debugdata): New function: Displays the contents of the debug directory and decodes codeview entries. (_bfd_XXi_swap_debugdir_in, _bfd_XXi_swap_debugdir_out) (_bfd_XXi_slurp_codeview_record, _bfd_XXi_write_codeview_record): Add functions for reading and writing debugdir and codeview records. * libpei.h (_bfd_XXi_swap_debugdir_in, _bfd_XXi_swap_debugdir_out) (_bfd_XXi_write_codeview_record): Add prototypes and macros. * libcoff-in.h (pe_tdata): Add build-id data. * libcoff.h: Regenerate. * coffcode.h (coff_write_object_contents): Run build_id after_write_object_contents hook. * pe.h (external_IMAGE_DEBUG_DIRECTORY, _CV_INFO_PDB70) (_CV_INFO_PDB20): Add structures and constants for debug directory and codeview records. * internal.h (internal_IMAGE_DEBUG_DIRECTORY, CODEVIEW_INFO): Add structures and constants for internal representation of debug directory and codeview records. * emultempl/elf32.em (id_note_section_size, read_hex, write_build_id): Move code for parsing build-id option and calculating the build-id to... * ldbuildid.c: New file. * ldbuildid.h: New file. * Makefile.am (CFILES, HFILES, OFILES, ld_new_SOURCES): Add new files. * Makefile.in: Regenerate. * ld.texinfo: Update --build-id description to mention COFF support. * NEWS: Mention support for COFF build ids. * emultempl/pe.em (gld${EMULATION_NAME}_handle_option): (pecoff_checksum_contents, write_build_id, setup_build_id) (gld_${EMULATION_NAME}_after_open): Handle and implement build-id option. * emultempl/pep.em: Likewise.
Diffstat (limited to 'bfd/libpei.h')
-rw-r--r--bfd/libpei.h12
1 files changed, 12 insertions, 0 deletions
diff --git a/bfd/libpei.h b/bfd/libpei.h
index 0fdafb0a132..ffcafded780 100644
--- a/bfd/libpei.h
+++ b/bfd/libpei.h
@@ -235,6 +235,9 @@
#define _bfd_XXi_swap_scnhdr_out _bfd_pex64i_swap_scnhdr_out
#define _bfd_XXi_swap_sym_in _bfd_pex64i_swap_sym_in
#define _bfd_XXi_swap_sym_out _bfd_pex64i_swap_sym_out
+#define _bfd_XXi_swap_debugdir_in _bfd_pex64i_swap_debugdir_in
+#define _bfd_XXi_swap_debugdir_out _bfd_pex64i_swap_debugdir_out
+#define _bfd_XXi_write_codeview_record _bfd_pex64i_write_codeview_record
#elif defined COFF_WITH_pep
@@ -266,6 +269,9 @@
#define _bfd_XXi_swap_scnhdr_out _bfd_pepi_swap_scnhdr_out
#define _bfd_XXi_swap_sym_in _bfd_pepi_swap_sym_in
#define _bfd_XXi_swap_sym_out _bfd_pepi_swap_sym_out
+#define _bfd_XXi_swap_debugdir_in _bfd_pepi_swap_debugdir_in
+#define _bfd_XXi_swap_debugdir_out _bfd_pepi_swap_debugdir_out
+#define _bfd_XXi_write_codeview_record _bfd_pepi_write_codeview_record
#else /* !COFF_WITH_pep */
@@ -297,6 +303,9 @@
#define _bfd_XXi_swap_scnhdr_out _bfd_pei_swap_scnhdr_out
#define _bfd_XXi_swap_sym_in _bfd_pei_swap_sym_in
#define _bfd_XXi_swap_sym_out _bfd_pei_swap_sym_out
+#define _bfd_XXi_swap_debugdir_in _bfd_pei_swap_debugdir_in
+#define _bfd_XXi_swap_debugdir_out _bfd_pei_swap_debugdir_out
+#define _bfd_XXi_write_codeview_record _bfd_pei_write_codeview_record
#endif /* !COFF_WITH_pep */
@@ -339,6 +348,9 @@ bfd_boolean _bfd_XX_print_private_bfd_data_common (bfd *, void *);
bfd_boolean _bfd_XX_bfd_copy_private_bfd_data_common (bfd *, bfd *);
void _bfd_XX_get_symbol_info (bfd *, asymbol *, symbol_info *);
bfd_boolean _bfd_XXi_final_link_postscript (bfd *, struct coff_final_link_info *);
+void _bfd_XXi_swap_debugdir_in (bfd *, void *, void *);
+unsigned _bfd_XXi_swap_debugdir_out (bfd *, void *, void *);
+unsigned _bfd_XXi_write_codeview_record (bfd *, file_ptr, CODEVIEW_INFO *);
/* The following are needed only for ONE of pe or pei, but don't
otherwise vary; peicode.h fixes up ifdefs but we provide the