aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 02:32:49 +0000
committerMichał Górny <mgorny@gentoo.org>2022-11-04 18:36:04 +0100
commit73c686b69a426cc226cd18e49880bb72d1c1db71 (patch)
tree2ebd56c86da8aa4a43439bc0bd51826ed940d4c3 /configure.ac
parent[3.10] gh-98517: Fix buffer overflows in _sha3 module (#98519) (diff)
downloadcpython-gentoo-3.9.15_p2.tar.gz
cpython-gentoo-3.9.15_p2.tar.bz2
cpython-gentoo-3.9.15_p2.zip
gh-99086: Build: Fix -Wimplicit-int in PTHREAD_SCOPE_SYSTEM check (#99085)gentoo-3.9.15_p2
Clang 16 makes -Wimplicit-int fatal by default. Avoids errors like: ``` conftest.c:142:7: error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Wimplicit-int] ``` Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d075d28479..f14b2167791 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3336,7 +3336,7 @@ if test "$posix_threads" = "yes"; then
void *foo(void *parm) {
return NULL;
}
- main() {
+ int main() {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) return (-1);