aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Ganssle <paul@ganssle.io>2021-01-12 13:17:52 -0500
committerGitHub <noreply@github.com>2021-01-12 10:17:52 -0800
commit0f66498fd8ee8644be6df963b86a1523f6069ddd (patch)
treeeabd48e262e7ffd165e7e49aa3e27c233b988594 /configure.ac
parentbpo-41994: Fix refcount issues in Python/import.c (GH-22632) (diff)
downloadcpython-0f66498fd8ee8644be6df963b86a1523f6069ddd.tar.gz
cpython-0f66498fd8ee8644be6df963b86a1523f6069ddd.tar.bz2
cpython-0f66498fd8ee8644be6df963b86a1523f6069ddd.zip
bpo-42874: Remove grep -qE options for Solaris 10 compatibility (GH-24200)
According to [bpo-42874](), some versions of grep do not support the `-q` and `-E` options. Although both options are used elsewhere in the configure script, this particular bit of validation can be achieved without them, so there's no real harm in using a grep call with no flags. Would be good to get some people taking advantage of the `--with-tzpath` arguments in the wild to try this out.. Local testing seems to indicate that this does the same thing, but I don't know that we have any buildbots using this option. Maybe @pablogsal? [bpo-42874]():
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 990d6bfdd81..08c462ac9f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2980,7 +2980,7 @@ validate_tzpath() {
# Bad paths are those that don't start with /
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
- if ( echo $1 | grep -qE '(^|:)(@<:@^/@:>@|$)' ); then
+ if ( echo $1 | grep '\(^\|:\)\(@<:@^/@:>@\|$\)' > /dev/null); then
AC_MSG_ERROR([--with-tzpath must contain only absolute paths, not $1])
return 1;
fi