aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2012-08-05 14:56:21 -0700
committerNed Deily <nad@acm.org>2012-08-05 14:56:21 -0700
commit03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02 (patch)
tree7a21b7f81229476b8d2ead2e099abc129375cba3 /setup.py
parentFix CGI tests to take into account the platform's line ending (issue #13119) (diff)
downloadcpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.tar.gz
cpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.tar.bz2
cpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.zip
Issue #15560: Fix building _sqlite3 extension on OS X with an SDK.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index f3886bf4376..65acb99f7c1 100644
--- a/setup.py
+++ b/setup.py
@@ -981,12 +981,12 @@ class PyBuildExt(build_ext):
if sys.platform == 'darwin':
sysroot = macosx_sdk_root()
- for d in inc_dirs + sqlite_inc_paths:
- f = os.path.join(d, "sqlite3.h")
-
+ for d_ in inc_dirs + sqlite_inc_paths:
+ d = d_
if sys.platform == 'darwin' and is_macosx_sdk_path(d):
- f = os.path.join(sysroot, d[1:], "sqlite3.h")
+ d = os.path.join(sysroot, d[1:])
+ f = os.path.join(d, "sqlite3.h")
if os.path.exists(f):
if sqlite_setup_debug: print("sqlite: found %s"%f)
with open(f) as file: