aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-04-01 18:49:29 +0200
committerGitHub <noreply@github.com>2020-04-01 18:49:29 +0200
commit65a796e5272f61b42792d3a8c69686558c1872c5 (patch)
tree138d64a8dd04ab4d1cac2eb5c415aa10e0bbe00f /setup.py
parentbpo-38527: fix configure script for Solaris (GH-16845) (diff)
downloadcpython-65a796e5272f61b42792d3a8c69686558c1872c5.tar.gz
cpython-65a796e5272f61b42792d3a8c69686558c1872c5.tar.bz2
cpython-65a796e5272f61b42792d3a8c69686558c1872c5.zip
bpo-40094: Add os.waitstatus_to_exitcode() (GH-19201)
Add os.waitstatus_to_exitcode() function to convert a wait status to an exitcode. Suggest waitstatus_to_exitcode() usage in the documentation when appropriate. Use waitstatus_to_exitcode() in: * multiprocessing, os, subprocess and _bootsubprocess modules; * test.support.wait_process(); * setup.py: run_command(); * and many tests.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3d3e5ac7db0..0357a0124f8 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,6 @@ import re
import sys
import sysconfig
from glob import glob
-from _bootsubprocess import _waitstatus_to_exitcode as waitstatus_to_exitcode
try:
@@ -98,7 +97,7 @@ Topic :: Software Development
def run_command(cmd):
status = os.system(cmd)
- return waitstatus_to_exitcode(status)
+ return os.waitstatus_to_exitcode(status)
# Set common compiler and linker flags derived from the Makefile,