aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2017-08-18 13:55:45 +0200
committerGitHub <noreply@github.com>2017-08-18 13:55:45 +0200
commitf0202bb349986ff264d06b15058dcde4062b7b7a (patch)
tree275fe2533265c911353a3c6db32668785f76e256 /setup.py
parentbpo-30721: Show correct syntax hint in Py3 when using Py2 redirection syntax ... (diff)
downloadcpython-f0202bb349986ff264d06b15058dcde4062b7b7a.tar.gz
cpython-f0202bb349986ff264d06b15058dcde4062b7b7a.tar.bz2
cpython-f0202bb349986ff264d06b15058dcde4062b7b7a.zip
Issue #30923: Revert flag that is not recognized by an obsolete gcc version. (#3132)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4f0f522bf8f..41aad8210d8 100644
--- a/setup.py
+++ b/setup.py
@@ -2119,9 +2119,6 @@ class PyBuildExt(build_ext):
else:
raise DistutilsError("_decimal: unsupported architecture")
- if 'gcc' in cc: # Suppressing the warnings in the source is too verbose.
- extra_compile_args.append('-Wno-implicit-fallthrough')
-
# Workarounds for toolchain bugs:
if sysconfig.get_config_var('HAVE_IPA_PURE_CONST_BUG'):
# Some versions of gcc miscompile inline asm: