diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 10 insertions, 1 deletions
@@ -827,6 +827,15 @@ class PyBuildExt(build_ext): exts.append( Extension('_sha1', ['sha1module.c'], depends=['hashlib.h']) ) + # SHA-3 (Keccak) module + sha3_depends = ['hashlib.h'] + keccak = os.path.join(os.getcwd(), srcdir, 'Modules', '_sha3', + 'keccak') + for pattern in ('*.c', '*.h', '*.macros'): + sha3_depends.extend(glob(os.path.join(keccak, pattern))) + exts.append(Extension("_sha3", ["_sha3/sha3module.c"], + depends=sha3_depends)) + # Modules that provide persistent dictionary-like semantics. You will # probably want to arrange for at least one of them to be available on # your machine, though none are defined by default because of library @@ -2092,7 +2101,7 @@ is also usable as an extension language for applications that need a programmable interface. The Python implementation is portable: it runs on many brands of UNIX, -on Windows, DOS, OS/2, Mac, Amiga... If your favorite system isn't +on Windows, DOS, Mac, Amiga... If your favorite system isn't listed here, it may still be supported, if there's a C compiler for it. Ask around on comp.lang.python -- or just try compiling Python yourself. |