aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'signal/Makefile')
-rw-r--r--signal/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/signal/Makefile b/signal/Makefile
index 077aaea6ad..de92558f2c 100644
--- a/signal/Makefile
+++ b/signal/Makefile
@@ -22,10 +22,14 @@ subdir := signal
include ../Makeconfig
-headers := signal.h sys/signal.h bits/signum.h bits/sigcontext.h \
- bits/sigaction.h bits/sigset.h bits/siginfo.h bits/sigstack.h \
- bits/sigthread.h bits/types/struct_sigstack.h bits/types/stack_t.h \
- bits/ss_flags.h
+headers := signal.h sys/signal.h \
+ bits/signum.h bits/sigcontext.h bits/sigaction.h \
+ bits/sigevent-consts.h bits/siginfo-consts.h \
+ bits/sigstack.h bits/sigthread.h bits/ss_flags.h \
+ bits/types/__sigset_t.h bits/types/sig_atomic_t.h \
+ bits/types/sigevent_t.h bits/types/siginfo_t.h \
+ bits/types/sigset_t.h bits/types/stack_t.h \
+ bits/types/struct_sigstack.h
routines := signal raise killpg \
sigaction sigprocmask kill \