aboutsummaryrefslogtreecommitdiff
path: root/units
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-06-25 17:24:09 +0200
committerLennart Poettering <lennart@poettering.net>2018-10-19 22:34:50 +0200
commit36695e880aff9c1525ed4efd5e42df1c62932a80 (patch)
tree72d454b675f2232833045b0e44d276ce1e7e6bfc /units
parentman: document new "boot-complete.target" unit (diff)
downloadsystemd-36695e880aff9c1525ed4efd5e42df1c62932a80.tar.gz
systemd-36695e880aff9c1525ed4efd5e42df1c62932a80.tar.bz2
systemd-36695e880aff9c1525ed4efd5e42df1c62932a80.zip
add new systemd-bless-boot.service that marks boots as successful
This is the counterpiece to the boot counting implemented in systemd-boot: if a boot is detected as successful we mark drop the counter again from the booted snippet or kernel image.
Diffstat (limited to 'units')
-rw-r--r--units/meson.build1
-rw-r--r--units/systemd-bless-boot.service.in22
2 files changed, 23 insertions, 0 deletions
diff --git a/units/meson.build b/units/meson.build
index 70eabe522..26a725b57 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -136,6 +136,7 @@ in_units = [
['systemd-backlight@.service', 'ENABLE_BACKLIGHT'],
['systemd-binfmt.service', 'ENABLE_BINFMT',
'sysinit.target.wants/'],
+ ['systemd-bless-boot.service', 'ENABLE_EFI HAVE_BLKID'],
['systemd-coredump@.service', 'ENABLE_COREDUMP'],
['systemd-firstboot.service', 'ENABLE_FIRSTBOOT',
'sysinit.target.wants/'],
diff --git a/units/systemd-bless-boot.service.in b/units/systemd-bless-boot.service.in
new file mode 100644
index 000000000..511d991d3
--- /dev/null
+++ b/units/systemd-bless-boot.service.in
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Mark the Current Boot Loader Entry as Good
+Documentation=man:systemd-bless-boot.service(8)
+DefaultDependencies=no
+Requires=boot-complete.target
+After=local-fs.target boot-complete.target
+Conflicts=shutdown.target
+Before=shutdown.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=@rootlibexecdir@/systemd-bless-boot good