summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild')
-rw-r--r--net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
new file mode 100644
index 0000000..052efaf
--- /dev/null
+++ b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild,v 1.3 2009/06/02 11:55:36 flameeyes Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="A top like console network traffic visualiser"
+HOMEPAGE="http://jnettop.kubs.info/"
+SRC_URI="http://jnettop.kubs.info/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86-linux"
+IUSE=""
+
+RDEPEND="net-libs/libpcap
+ >=dev-libs/glib-2.0.1"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README .jnettop
+}