aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2018-06-29 10:45:07 -0500
committerDoug Goldstein <cardoe@cardoe.com>2018-06-29 10:58:39 -0500
commitaf56c718bb159b78d11f1bf8852771d160f7b005 (patch)
tree8b7052d370a02b5a27d45ae9e1bc9c09b239ddeb /Cargo.toml
parentseparate functionality into a lib (diff)
downloadcargo-ebuild-af56c718bb159b78d11f1bf8852771d160f7b005.tar.gz
cargo-ebuild-af56c718bb159b78d11f1bf8852771d160f7b005.tar.bz2
cargo-ebuild-af56c718bb159b78d11f1bf8852771d160f7b005.zip
switch from cargo to structopt for arg parsing
Cargo exported its own arg parsing interface that's based on clap. To break the dependence on Cargo for everything, switch to parsing arguments in the binary using structopt.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f8ee0ea..7e7ccf4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,6 +26,5 @@ travis-ci = { repository = "cardoe/cargo-ebuild" }
[dependencies]
cargo = "^0.21"
-serde = "1"
-serde_derive = "1"
+structopt = "^0.2"
time = "^0.1"