aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2019-12-23 20:21:08 -0600
committerDoug Goldstein <cardoe@cardoe.com>2020-01-26 09:20:17 -0600
commitbf34b38ed191c9ecb6d405f372e6ccb4d0625cb2 (patch)
treec9ef4daac86f196ef3bb572b67314e91f7a4ae41 /Cargo.toml
parentswitch to cargo_metadata for dep info (diff)
downloadcargo-ebuild-bf34b38ed191c9ecb6d405f372e6ccb4d0625cb2.tar.gz
cargo-ebuild-bf34b38ed191c9ecb6d405f372e6ccb4d0625cb2.tar.bz2
cargo-ebuild-bf34b38ed191c9ecb6d405f372e6ccb4d0625cb2.zip
include license info for depends
Since dependencies are compiled into the final binary, those licenses must be included in the ebuild generated by the tool. Gather up the licenses from each of the dependencies and include them in an AND pattern since computing the OR pattern as well is a bit more effort but this is an improvement.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 828d38d..c621df6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,5 +32,6 @@ maintenance = { status = "passively-maintained" }
cargo = "^0.37"
cargo_metadata = "^0.9"
failure = "^0.1"
+itertools = "^0.8"
structopt = "^0.3"
time = "^0.1"