summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ps3-sources/ps3-sources-2.6.23.ebuild')
-rw-r--r--sys-kernel/ps3-sources/ps3-sources-2.6.23.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/ps3-sources/ps3-sources-2.6.23.ebuild b/sys-kernel/ps3-sources/ps3-sources-2.6.23.ebuild
new file mode 100644
index 0000000..793c06f
--- /dev/null
+++ b/sys-kernel/ps3-sources/ps3-sources-2.6.23.ebuild
@@ -0,0 +1,32 @@
+
+#K_WANT_GENPATCHES="base extras"
+#K_GENPATCHES_VER="15"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+ETYPE="sources"
+inherit kernel-2 eutils
+detect_version
+
+DESCRIPTION="vanilla plus ps3 patches"
+HOMEPAGE=""
+
+PS3_PATCHES_URI="http://dev.gentoo.org/~ranger/downloads/ps3/${PV}-ps3updates.diff.bz2"
+
+SRC_URI="${KERNEL_URI} ${PS3_PATCHES_URI}"
+
+KEYWORDS="ppc ppc64"
+
+
+src_unpack() {
+ kernel-2_src_unpack
+ #cd ${S}
+ cd ..
+ epatch ${DISTDIR}/${PV}-ps3updates.diff.bz2
+
+}
+
+
+pkg_postinst() {
+ postinst_sources
+}
+