aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-07-07 15:17:03 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-07-07 15:17:03 -0400
commit9d1e3c86817c6afd01201c83a9640a8850ffbc4c (patch)
tree72dc3c98700f5978b675a66a89a38707ca0e86c3 /catalyst
parentRemoved an unused test overlay (diff)
downloadclustering-livecd-9d1e3c86817c6afd01201c83a9640a8850ffbc4c.tar.gz
clustering-livecd-9d1e3c86817c6afd01201c83a9640a8850ffbc4c.tar.bz2
clustering-livecd-9d1e3c86817c6afd01201c83a9640a8850ffbc4c.zip
Removed local livecd.sh, we rely on releng to do a good job ;)
Diffstat (limited to 'catalyst')
-rw-r--r--catalyst/livecd/2008.0/scripts/livecd.sh68
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec2
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec1
3 files changed, 2 insertions, 69 deletions
diff --git a/catalyst/livecd/2008.0/scripts/livecd.sh b/catalyst/livecd/2008.0/scripts/livecd.sh
deleted file mode 100644
index 3d81dc2..0000000
--- a/catalyst/livecd/2008.0/scripts/livecd.sh
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/bash
-# This is where we will put any release-specific fsscript code
-
-if [[ -e /etc/conf.d/clock ]]
-then
- sed -i -e 's/#TIMEZONE="Factory"/TIMEZONE="UTC"/' /etc/conf.d/clock
-fi
-
-case `uname -m` in
- alpha)
- echo >> /etc/sysctl.conf
- echo "# Disable UAC on Alpha" >> /etc/sysctl.conf
- echo "kernel.uac.noprint = 1" >> /etc/sysctl.conf
- ;;
- i?86|x86_64)
- sed -i 's/DRIVER fbdev/DRIVER vesa/' /usr/share/hwdata/Cards
- ;;
-esac
-
-# Enforce a unicode font by default
-sed -e 's/CONSOLEFONT="default8x16"/CONSOLEFONT="lat1-16"/' \
- -e '/^#CONSOLETRANSLATION="8859-1_to_uni"/ s/^#//' \
- -i /etc/conf.d/consolefont
-
-# This is necessary because /home/gentoo in the squashfs ends up getting owned
-# by whoever the owner of the overlay files were on the build box. This causes
-# weird stuff to happen like X failing to start because it doesn't have the
-# ability to write the .Xauthority file
-if [[ -d /home/gentoo ]]
-then
- chown -R gentoo:users /home/gentoo
-fi
-
-echo "#####################################################" > /etc/fstab
-echo "## ATTENTION: THIS IS THE FSTAB ON THE LIVECD ##" >> /etc/fstab
-echo "## PLEASE EDIT THE FSTAB at /mnt/gentoo/etc/fstab ##" >> /etc/fstab
-echo "#####################################################" >> /etc/fstab
-
-# fstab tweaks
-echo "tmpfs / tmpfs defaults 0 0" >> /etc/fstab
-echo "tmpfs /lib/firmware tmpfs defaults 0 0" >> /etc/fstab
-echo "tmpfs /usr/portage tmpfs defaults 0 0" >> /etc/fstab
-echo "tmpfs /boot tmpfs defaults 0 0" >> /etc/fstab
-
-# pull /boot from the CD
-cd /boot && ls -1 | grep -v boot > /usr/livecd/bootfiles.txt
-mv -f System.map* /usr/livecd
-rm -rf /boot/*
-cat << EOF >> /etc/conf.d/local.start
-if [ -n "$(ls /mnt/cdrom)" ]
-then
- INITR_TMP=`ls -1 /mnt/cdrom/*/*.gz | head -n 1`
- INITRAMFS=`basename ${INITR_TMP}`
- KERNEL=${INITRAMFS/.gz/}
- initramfs=`grep initr /usr/livecd/bootfiles.txt | head -n 1`
- kernel=`grep kernel /usr/livecd/bootfiles.txt | head -n 1`
- cp -f /mnt/cdrom/*/${INITRAMFS} /boot/${initramfs}
- cp -f /mnt/cdrom/*/${KERNEL} /boot/${kernel}
- cp -f /usr/livecd/System.map* /boot
-fi
-EOF
-
-#[ -x /usr/bin/ktelnet ] && ln -sf /usr/bin/ktelnet /usr/bin/telnet
-#[ -x /usr/bin/kftp ] && ln -sf /usr/bin/kftp /usr/bin/ftp
-
-# Remove DefaultColorDepth
-[ -e /etc/X11/xorg.conf.in ] && sed -i -e '/DefaultColorDepth/d' /etc/X11/xorg.conf.in
-
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
index 19c5b15..2cb320a 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
@@ -9,7 +9,7 @@ source_subpath: default/stage3-amd64-desktop-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_desktop
-portage_overlay: /var/git/clustering-livecd/overlay/
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
### end
# Kyron: added
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
index e9fe8d4..e949a95 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
@@ -9,6 +9,7 @@ source_subpath: default/livecd-stage1-amd64-installer-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_desktop
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
livecd/iso: /tmp/livecd-amd64-installer-2008.0.iso
livecd/volid: x86_64 Gentoo Clustering LiveCD