aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-03-21 10:52:24 +0000
committerRobert Piasek <dagger@gentoo.org>2009-03-21 10:52:24 +0000
commit9f94f4022671d88247ed6962f0b698020c8fef50 (patch)
treeed1bfb8db188b9fef640f0ce69e80cc0c43bf3e3 /dev-python
parentoops, last time forget commit warning patch (diff)
downloadembedded-cross-9f94f4022671d88247ed6962f0b698020c8fef50.tar.gz
embedded-cross-9f94f4022671d88247ed6962f0b698020c8fef50.tar.bz2
embedded-cross-9f94f4022671d88247ed6962f0b698020c8fef50.zip
Added debian patch to fix unicode problems
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-edje/Manifest3
-rw-r--r--dev-python/python-edje/files/0001-fix-unicode-conversion.patch41
-rw-r--r--dev-python/python-edje/python-edje-20090313.ebuild2
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/python-edje/Manifest b/dev-python/python-edje/Manifest
index eb3ed70..8e613dc 100644
--- a/dev-python/python-edje/Manifest
+++ b/dev-python/python-edje/Manifest
@@ -1,2 +1,3 @@
+AUX 0001-fix-unicode-conversion.patch 1334 RMD160 2fba4b976e0aa0e63904e0384a09f19fa684912f SHA1 18c5922a32dd8e53b979f5bce0a68d04696a1d92 SHA256 09f42c9c392424cf1f4af4664e4ba66a9f0e5ca0aa835d696a6ca31bf359c79e
EBUILD python-edje-20090212.ebuild 426 RMD160 8c0e8224ce2c7dc6b5b1dfbe80beccfdb3b0d95e SHA1 6784c4f6c3bf71a7b20622f587d2a0afac0324d6 SHA256 d02870a0eba501d30cf7bf2b8a080c725bf7b3cafd1c89b647568edf2f68fbb3
-EBUILD python-edje-20090313.ebuild 426 RMD160 8c0e8224ce2c7dc6b5b1dfbe80beccfdb3b0d95e SHA1 6784c4f6c3bf71a7b20622f587d2a0afac0324d6 SHA256 d02870a0eba501d30cf7bf2b8a080c725bf7b3cafd1c89b647568edf2f68fbb3
+EBUILD python-edje-20090313.ebuild 475 RMD160 dd31da0e6b8e94ab2361e0e5a9f393e076fef8b5 SHA1 db5f3c35a99a0f5c9d67a87b8f9eaf30600ef669 SHA256 cc97f536f3e95c2832d0c3757965bec33069d73e153f0e9f8b71a21d2bc078ed
diff --git a/dev-python/python-edje/files/0001-fix-unicode-conversion.patch b/dev-python/python-edje/files/0001-fix-unicode-conversion.patch
new file mode 100644
index 0000000..7964e09
--- /dev/null
+++ b/dev-python/python-edje/files/0001-fix-unicode-conversion.patch
@@ -0,0 +1,41 @@
+From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
+From: Jan Luebbe <jluebbe@debian.org>
+Date: Sat, 9 Aug 2008 18:30:04 +0200
+Subject: [PATCH] fix unicode conversion
+
+---
+ edje/edje.c_edje_object.pxi | 11 +++++++----
+ 1 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
+index 0f4da68..21c237e 100644
+--- a/edje/edje.c_edje_object.pxi
++++ b/edje/edje.c_edje_object.pxi
+@@ -391,17 +391,20 @@ cdef public class Edje(evas.c_evas.Object) [object PyEdje, type PyEdje_Type]:
+ else:
+ raise TypeError("func must be callable or None")
+
+- def part_text_set(self, char *part, char *text):
+- edje_object_part_text_set(self.obj, part, text)
++ def part_text_set(self, char *part, text):
++ cdef char *s
++ u = text.encode("utf8")
++ s = u
++ edje_object_part_text_set(self.obj, part, s)
+
+ def part_text_get(self, char *part):
+- "@rtype: str"
++ "@rtype: unicode"
+ cdef char *s
+ s = edje_object_part_text_get(self.obj, part)
+ if s == NULL:
+ return None
+ else:
+- return s
++ return s.decode("utf8")
+
+ def part_swallow(self, char *part, c_evas.Object obj):
+ """Swallows an object into the edje
+--
+1.5.6.3
+
diff --git a/dev-python/python-edje/python-edje-20090313.ebuild b/dev-python/python-edje/python-edje-20090313.ebuild
index 20134ff..4a1edd3 100644
--- a/dev-python/python-edje/python-edje-20090313.ebuild
+++ b/dev-python/python-edje/python-edje-20090313.ebuild
@@ -12,6 +12,8 @@ SLOT="0"
KEYWORDS="~arm ~amd64 ~x86"
IUSE=""
+E17_PATCHES="0001-fix-unicode-conversion.patch"
+
RDEPEND="=media-libs/edje-${PVR}
=dev-python/python-evas-${PVR}"