aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-07-09 08:57:18 +0000
committerRobert Piasek <dagger@gentoo.org>2009-07-09 08:57:18 +0000
commit17569c4aeb6935e3597b0fc1836ddf3671075343 (patch)
tree34d397eef8cfa18de6cf54f4ec02d5fe14225efc /sys-mobilephone/freesmartphone-framework
parentModified slim with the possibility to start a virtual keyboard. See config file. (diff)
downloadembedded-cross-17569c4aeb6935e3597b0fc1836ddf3671075343.tar.gz
embedded-cross-17569c4aeb6935e3597b0fc1836ddf3671075343.tar.bz2
embedded-cross-17569c4aeb6935e3597b0fc1836ddf3671075343.zip
Updated dependencies
Diffstat (limited to 'sys-mobilephone/freesmartphone-framework')
-rw-r--r--sys-mobilephone/freesmartphone-framework/Manifest4
-rw-r--r--sys-mobilephone/freesmartphone-framework/freesmartphone-framework-20090704.ebuild15
-rw-r--r--sys-mobilephone/freesmartphone-framework/freesmartphone-framework-9999.ebuild5
3 files changed, 14 insertions, 10 deletions
diff --git a/sys-mobilephone/freesmartphone-framework/Manifest b/sys-mobilephone/freesmartphone-framework/Manifest
index 443690d..c769546 100644
--- a/sys-mobilephone/freesmartphone-framework/Manifest
+++ b/sys-mobilephone/freesmartphone-framework/Manifest
@@ -4,5 +4,5 @@ AUX freesmartphone-framework-20090704-setup-paths.patch 3480 RMD160 d71648089899
AUX freesmartphone-framework-9999-setup-paths.patch 3477 RMD160 47547e3175ea437023091073423016bc5db355eb SHA1 9754e5f2ee2de24c13b7e74fd0d7204feec260b7 SHA256 1389bea2c4b872a8557ad079d8eda70fcf2698043bdc8ca3f06e706b5d2582de
EBUILD freesmartphone-framework-0.5.1.ebuild 1339 RMD160 9f87e800434d665a52dad75a21185fa61e283d6d SHA1 75361271cc62300a9a89670a8b60ae5c4b8cd8d4 SHA256 15c3dcb4927a7b4041ac425485e484139e377e7b601e07cdbbac229792ce5702
EBUILD freesmartphone-framework-0.5.ebuild 1343 RMD160 402030ad32e8184b1a1b9ca2746b4d595b292014 SHA1 0787bff7ee46b9e38aa7ca1066c8c325077b965c SHA256 4f28fbc685ca00f283da7e5b341a98adb797fb00c15fa9d14862ea7e4578fc8b
-EBUILD freesmartphone-framework-20090704.ebuild 1355 RMD160 d7a76d73af987b2052f139f499a653dfa3b6b8e3 SHA1 0ab940dbf5e56e6b8daa63af65f6f58943a4e9da SHA256 7df6f4cfa21e83a58e2c2704d1b19d4e729e036c28561352e84c6599701fe8cd
-EBUILD freesmartphone-framework-9999.ebuild 1485 RMD160 f55b40a0dbe94344b741daa96c0c8b26562960f7 SHA1 b3ef8522e28eb68348d460595ed79e668eaeed3a SHA256 33579c51962ed9bc39b597de51d1ea636e78eb697a27d59c9ff9198097bd34c9
+EBUILD freesmartphone-framework-20090704.ebuild 1353 RMD160 ed8bebf61a18872b663a65fcf4689ec035d65de6 SHA1 0404228517849ee6ed03b92d4b51ff62afba09d1 SHA256 3c1741662d1801b0ea5d863a6c1ae5991166ee7f9161f524cb05d6ef15780ff7
+EBUILD freesmartphone-framework-9999.ebuild 1510 RMD160 1d14439cc9540a0bdc32b6a3b8a9cb6583eeeefb SHA1 262b9eef4870494b08302291eff843214f0ffda8 SHA256 4331ac527ce5c205c93d00f82adccca6ff85480426d1c84e07c2350d2ad141c5
diff --git a/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-20090704.ebuild b/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-20090704.ebuild
index 8078ef8..7c1aa5a 100644
--- a/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-20090704.ebuild
+++ b/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-20090704.ebuild
@@ -5,6 +5,8 @@
inherit distutils
inherit git
+EAPI=2
+
DESCRIPTION="The FreeSmartPhone.org framework APIs."
HOMEPAGE="http://www.freesmartphone.org/"
@@ -27,18 +29,17 @@ RDEPEND="dev-python/dbus-python
dev-python/pyalsaaudio
dev-lang/python[threads]
virtual/alsa-scenarios
- gsm? ( sys-mobilephone/gsm0710muxd )
+ gsm? (
+ ( || ( sys-mobilephone/gsm0710muxd sys-mobilephone/fso-abyss ) )
+ net-dialup/ppp
+ )
gps? ( || ( sci-geosciences/fso-gpsd sci-geosciences/gpsd ) )
readline? ( sys-libs/readline )"
+
DEPEND="dev-python/cython
dev-python/setuptools"
-src_unpack() {
- # Fetch and unpack current git sources
- git_src_unpack
-
- cd "${S}"
-
+src_prepare() {
# Change the paths for setup.py and add the example config file
epatch "${FILESDIR}/${P}-setup-paths.patch"
}
diff --git a/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-9999.ebuild b/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-9999.ebuild
index 50f333a..8a3a592 100644
--- a/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-9999.ebuild
+++ b/sys-mobilephone/freesmartphone-framework/freesmartphone-framework-9999.ebuild
@@ -35,7 +35,10 @@ RDEPEND="dev-python/dbus-python
dev-python/pyalsaaudio
dev-lang/python[threads]
virtual/alsa-scenarios
- gsm? ( || ( sys-mobilephone/gsm0710muxd sys-mobilephone/fso-abyss ) )
+ gsm? (
+ ( || ( sys-mobilephone/gsm0710muxd sys-mobilephone/fso-abyss ) )
+ net-dialup/ppp
+ )
gps? ( || ( sci-geosciences/fso-gpsd sci-geosciences/gpsd ) )
readline? ( sys-libs/readline )"
DEPEND="dev-python/cython