aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Spielmann <spielc@gmail.com>2009-01-30 20:17:28 +0000
committerChristoph Spielmann <spielc@gmail.com>2009-01-30 20:17:28 +0000
commit774f87ce113af843786b10db791244171c88855f (patch)
tree96b4aca70b49136903dc2f1901db941e7d88e86f /sys-mobilephone/ophonekitd
parentversion bump; necessary for openmoko-dialer3 (diff)
downloadembedded-cross-774f87ce113af843786b10db791244171c88855f.tar.gz
embedded-cross-774f87ce113af843786b10db791244171c88855f.tar.bz2
embedded-cross-774f87ce113af843786b10db791244171c88855f.zip
initial commit of shr-application ophonekitd
Diffstat (limited to 'sys-mobilephone/ophonekitd')
-rw-r--r--sys-mobilephone/ophonekitd/Manifest3
-rwxr-xr-xsys-mobilephone/ophonekitd/files/80ophonekitd3
-rw-r--r--sys-mobilephone/ophonekitd/ophonekitd-0.1.ebuild45
-rw-r--r--sys-mobilephone/ophonekitd/ophonekitd-20090127.ebuild51
4 files changed, 102 insertions, 0 deletions
diff --git a/sys-mobilephone/ophonekitd/Manifest b/sys-mobilephone/ophonekitd/Manifest
new file mode 100644
index 0000000..e8d4ba6
--- /dev/null
+++ b/sys-mobilephone/ophonekitd/Manifest
@@ -0,0 +1,3 @@
+AUX 80ophonekitd 71 RMD160 54be0910d9a6c52c2e84ed59f1d9637b00b6c663 SHA1 81cf50e81e2de6253e558ba5227bd9140b0f77fe SHA256 ab5019bd6daa0484e0cc6e5d3e7c0c1710626977d035ab9d597aeaccd0870104
+EBUILD ophonekitd-0.1.ebuild 1002 RMD160 043230b3bd7306634d32b6a1d44fda42dedfcfdc SHA1 48198a33c8e6541c2628338fb3f85b7eefb34097 SHA256 76b6bf6e028c7d16e0bcd193c87f3adfa04cf195edca4ffe4b884c330891c25d
+EBUILD ophonekitd-20090127.ebuild 1402 RMD160 549b36d7feadfbda539b7d58f07a1b35d19630ee SHA1 5f2a2ad29dab20958cd4e902a83bec59b3de2839 SHA256 31ab1cb13ef0eb9958fc61dc70fa8490a31d8d14e386f25458c1a3f7215bf3bd
diff --git a/sys-mobilephone/ophonekitd/files/80ophonekitd b/sys-mobilephone/ophonekitd/files/80ophonekitd
new file mode 100755
index 0000000..fbc6380
--- /dev/null
+++ b/sys-mobilephone/ophonekitd/files/80ophonekitd
@@ -0,0 +1,3 @@
+#!/bin/sh -e
+ophonekitd >> /var/log/ophonekitd.log 2>&1 &
+renice -3 $!
diff --git a/sys-mobilephone/ophonekitd/ophonekitd-0.1.ebuild b/sys-mobilephone/ophonekitd/ophonekitd-0.1.ebuild
new file mode 100644
index 0000000..51e2a28
--- /dev/null
+++ b/sys-mobilephone/ophonekitd/ophonekitd-0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+DESCRIPTION="shr ophonekitd"
+HOMEPAGE="http://www.freesmartphone.org/"
+
+EGIT_REPO_URI="http://shr.bearstech.com/repo/shr.git"
+EGIT_TREE="36fd931e039aa7824cbab28d9d575bd892e191a7"
+EGIT_PROJECT="ophonekitd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm"
+IUSE=""
+DOCS="README"
+
+RDEPEND="${DEPEND}
+ sys-mobilephone/frameworkd-phonegui-efl"
+DEPEND="dev-libs/dbus-glib
+ sys-mobilephone/libframeworkd-glib
+ sys-mobilephone/frameworkd-phonegui"
+
+#S=${WORKDIR}/ophonekitd/ophonekitd
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+ einfo "${S}"
+ cd "${S}"/ophonekitd
+ eautoreconf || die "autoreconf failed"
+ glib-gettextize --force --copy || die "glib-gettextize failed"
+}
+
+src_compile() {
+ cd "${S}"/ophonekitd
+ econf || die "econf failed"
+}
+
+src_install() {
+ cd "${S}"/ophonekitd
+ emake DESTDIR="${D}" install || die "emake failed"
+}
diff --git a/sys-mobilephone/ophonekitd/ophonekitd-20090127.ebuild b/sys-mobilephone/ophonekitd/ophonekitd-20090127.ebuild
new file mode 100644
index 0000000..11793a6
--- /dev/null
+++ b/sys-mobilephone/ophonekitd/ophonekitd-20090127.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+DESCRIPTION="shr ophonekitd"
+HOMEPAGE="http://www.freesmartphone.org/"
+
+EGIT_REPO_URI="http://shr.bearstech.com/repo/shr.git"
+EGIT_TREE="8f78cb80d38831ab264881bad33db748db9b5198"
+EGIT_PROJECT="ophonekitd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm"
+IUSE=""
+DOCS="README"
+
+RDEPEND="${DEPEND}
+ sys-mobilephone/libframeworkd-glib
+ sys-mobilephone/frameworkd-phonegui
+ sys-mobilephone/frameworkd-phonegui-efl
+ dev-db/sqlite"
+DEPEND="dev-libs/dbus-glib"
+
+#S=${WORKDIR}/ophonekitd/ophonekitd
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+ einfo "${S}"
+ cd "${S}"/ophonekitd
+ eautoreconf || die "autoreconf failed"
+ glib-gettextize --force --copy || die "glib-gettextize failed"
+}
+
+src_compile() {
+ cd "${S}"/ophonekitd
+ econf || die "econf failed"
+}
+
+src_install() {
+ cd "${S}"/ophonekitd
+ emake DESTDIR="${D}" install || die "emake failed"
+
+ #install data files (Xsession-file, sqlitedb and dbus-configuration-file)
+ install -D -m 755 "${S}"/ophonekitd/data/80ophonekitd "${D}/etc/X11/Xsession.d/80ophonekitd"
+ install -D -m 755 "${S}"/ophonekitd/data/phonelog-database.sql "${D}/usr/share/ophonekitd/phonelog-database.sql"
+ install -D -m 644 "${S}"/ophonekitd/data/ophonekitd.conf "${D}/etc/dbus-1/system.d/ophonekitd.conf"
+}