aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Spielmann <spielc@gmail.com>2009-01-18 20:49:48 +0000
committerChristoph Spielmann <spielc@gmail.com>2009-01-18 20:49:48 +0000
commit57524934b43aef3e7efc48a1589dc1c954247c45 (patch)
treec23635a678003ae68ee08c6e375476b0bf30643d /sys-mobilephone
parentCosmetic fixes (add correct homepage and license entry) (diff)
downloadembedded-cross-57524934b43aef3e7efc48a1589dc1c954247c45.tar.gz
embedded-cross-57524934b43aef3e7efc48a1589dc1c954247c45.tar.bz2
embedded-cross-57524934b43aef3e7efc48a1589dc1c954247c45.zip
Initial commit of frameworkd-phonegui-efl
Diffstat (limited to 'sys-mobilephone')
-rw-r--r--sys-mobilephone/frameworkd-phonegui-efl/Manifest1
-rw-r--r--sys-mobilephone/frameworkd-phonegui-efl/frameworkd-phonegui-efl-0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-mobilephone/frameworkd-phonegui-efl/Manifest b/sys-mobilephone/frameworkd-phonegui-efl/Manifest
new file mode 100644
index 0000000..8b0d77c
--- /dev/null
+++ b/sys-mobilephone/frameworkd-phonegui-efl/Manifest
@@ -0,0 +1 @@
+EBUILD frameworkd-phonegui-efl-0.1.ebuild 981 RMD160 bf54d795f214ca174e1d4791d18fd19b20fbba10 SHA1 a0d148ee5f8d44f537153209d2603066fe737614 SHA256 7c1c2947647ed10b19f79a1b6bada14d93f3c58b458f639a6cfe02294725c2f2
diff --git a/sys-mobilephone/frameworkd-phonegui-efl/frameworkd-phonegui-efl-0.1.ebuild b/sys-mobilephone/frameworkd-phonegui-efl/frameworkd-phonegui-efl-0.1.ebuild
new file mode 100644
index 0000000..a47ec11
--- /dev/null
+++ b/sys-mobilephone/frameworkd-phonegui-efl/frameworkd-phonegui-efl-0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+DESCRIPTION="shr frameworkd-phonegui-efl"
+HOMEPAGE="http://trac.shr-project.org/trac"
+
+EGIT_REPO_URI="http://shr.bearstech.com/repo/shr.git"
+EGIT_TREE="36fd931e039aa7824cbab28d9d575bd892e191a7"
+EGIT_PROJECT="frameworkd-phonegui-efl"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm"
+IUSE=""
+DOCS="README"
+
+RDEPEND="${DEPEND}"
+DEPEND="dev-libs/dbus-glib
+ sys-mobilephone/libframeworkd-glib
+ x11-libs/ecore
+ x11-libs/elementary
+ x11-libs/etk"
+
+#S=${WORKDIR}/ophonekitd/ophonekitd
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+ einfo "${S}"
+ cd "${S}"/libframeworkd-phonegui-efl
+ eautoreconf || die "autoreconf failed"
+ glib-gettextize --force --copy || die "glib-gettextize failed"
+}
+
+src_compile() {
+ cd "${S}"/libframeworkd-phonegui-efl
+ econf --with-edje-cc=/usr/bin/edje_cc || die "econf failed"
+}
+
+src_install() {
+ cd "${S}"/libframeworkd-phonegui-efl
+ emake DESTDIR="${D}" install || die "emake failed"
+}