aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-mobilephone/shr-settings/shr-settings-99999999.ebuild')
-rw-r--r--sys-mobilephone/shr-settings/shr-settings-99999999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-mobilephone/shr-settings/shr-settings-99999999.ebuild b/sys-mobilephone/shr-settings/shr-settings-99999999.ebuild
new file mode 100644
index 0000000..e418d8f
--- /dev/null
+++ b/sys-mobilephone/shr-settings/shr-settings-99999999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git distutils
+
+DESCRIPTION="shr-settings; a gui for changing phone settings from the shr-project"
+HOMEPAGE="http://trac.shr-project.org/trac"
+
+EGIT_REPO_URI="http://shr.bearstech.com/repo/shr-settings.git"
+EGIT_PROJECT="shr-settings"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ >=dev-python/python-elementary-20090422
+ >=dev-python/python-edje-20090422
+ >=dev-python/python-e_dbus-20090422
+ >=dev-python/python-ecore-20090422"
+DEPEND="dev-python/setuptools"
+
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/shr-settings-20090418-setup.py.patch
+}
+
+src_install() {
+ distutils_src_install
+}