aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e/e-20090108.ebuild')
-rw-r--r--x11-wm/e/e-20090108.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/x11-wm/e/e-20090108.ebuild b/x11-wm/e/e-20090108.ebuild
new file mode 100644
index 0000000..4838d18
--- /dev/null
+++ b/x11-wm/e/e-20090108.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Enlightenment E17 window manager"
+HOMEPAGE="http://www.enlightenment.org/"
+ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/${PN}"
+ESVN_REVISION="r38500"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="X alsa dbus nls files pam"
+
+inherit autotools subversion
+
+RDEPEND="dev-libs/eet
+ =dev-libs/eina-20090108
+ =dev-libs/efreet-20090108
+ =x11-libs/ecore-20090108
+ =x11-libs/evas-20090108
+ >=media-libs/edje-0.5.0
+ dbus? ( =x11-libs/e_dbus-20090108 )
+ X? ( x11-libs/libX11 )
+ alsa? ( media-libs/alsa-lib )
+ pam? ( sys-libs/pam )"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0
+ media-libs/edje
+ dev-util/cvs"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if use dbus && ! built_with_use x11-libs/e_dbus hal; then
+ die "Please rebuild x11-libs/e_dbus with the hal use flag enabled!"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ touch README
+ touch ABOUT-NLS
+
+ autopoint -f || die "autopoint failed"
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} \
+ $(use_enable alsa) \
+ $(use_enable files) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with X x) \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib\
+ --with-edje-cc=/usr/bin/edje_cc\
+ --with-eet-eet=/usr/bin/eet"
+
+ econf $myconf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+
+ keepdir /etc/xdg/menus
+ insinto /etc/xdg/menus
+ newins "${FILESDIR}/applications.menu" applications.menu
+
+}