summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-05 19:43:04 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-05 19:43:04 +0000
commit09e296fd82c3daddfd893b6a852ece471716db58 (patch)
tree776fb1725c3d19f98268a3269d001a60a1d5a496 /x11-libs
parentAdd inkscape2edc and gimp-edje-export.py to docs (diff)
downloadenlightenment-09e296fd82c3daddfd893b6a852ece471716db58.tar.gz
enlightenment-09e296fd82c3daddfd893b6a852ece471716db58.tar.bz2
enlightenment-09e296fd82c3daddfd893b6a852ece471716db58.zip
Add beta version of e_dbus
(Portage version: 2.2_rc88-r1/svn/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/e_dbus/ChangeLog8
-rw-r--r--x11-libs/e_dbus/e_dbus-1.0.0_beta.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-libs/e_dbus/ChangeLog b/x11-libs/e_dbus/ChangeLog
index 7cae4b9..f8dfc3c 100644
--- a/x11-libs/e_dbus/ChangeLog
+++ b/x11-libs/e_dbus/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for x11-libs/e_dbus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*e_dbus-1.0.0_beta (03 Oct 2010)
+
+ 03 Oct 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +e_dbus-1.0.0_beta.ebuild:
+ Add beta release of e_dbus
+
20 Dec 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+e_dbus-0.5.0.063.ebuild, e_dbus-9999.ebuild:
Version bump for e_dbus snapshot
diff --git a/x11-libs/e_dbus/e_dbus-1.0.0_beta.ebuild b/x11-libs/e_dbus/e_dbus-1.0.0_beta.ebuild
new file mode 100644
index 0000000..3218b7b
--- /dev/null
+++ b/x11-libs/e_dbus/e_dbus-1.0.0_beta.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_P=${P/_beta/.beta}
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth connman +hal +libnotify ofono static-libs ukit"
+
+RDEPEND=">=dev-libs/eina-1.0.0_beta
+ >=x11-libs/ecore-1.0.0_beta
+ sys-apps/dbus
+ libnotify? ( >=x11-libs/evas-1.0.0_beta )
+ hal? ( sys-apps/hal )
+ ukit? ( sys-power/upower sys-fs/udisks )
+"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman)
+ $(use_enable doc)
+ $(use_enable hal ehal)
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable ukit eukit)
+ "
+ enlightenment_src_configure
+}