aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2009-12-28 04:15:10 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2009-12-28 04:15:10 -0200
commit01b86a40cb0f47fb68fbf9096e89f60e1af1def7 (patch)
tree05f23e1391b3a6b37df5cddc901f8cda959fab44 /ebuilds
parentadded support to build doc on setup.py (diff)
downloadg-octave-01b86a40cb0f47fb68fbf9096e89f60e1af1def7.tar.gz
g-octave-01b86a40cb0f47fb68fbf9096e89f60e1af1def7.tar.bz2
g-octave-01b86a40cb0f47fb68fbf9096e89f60e1af1def7.zip
updated the live ebuild
Diffstat (limited to 'ebuilds')
-rw-r--r--ebuilds/g-octave-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/ebuilds/g-octave-9999.ebuild b/ebuilds/g-octave-9999.ebuild
index 46c2fd3..3ea314c 100644
--- a/ebuilds/g-octave-9999.ebuild
+++ b/ebuilds/g-octave-9999.ebuild
@@ -4,8 +4,6 @@
EAPI="2"
-NEED_PYTHON="2.6"
-
inherit distutils mercurial
DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
@@ -17,6 +15,16 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-RDEPEND="sys-apps/portage[-python3]"
+CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
+DEPEND="${CDEPEND}
+ dev-python/docutils"
+RDEPEND="${CDEPEND}
+ || ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
S="${WORKDIR}/${PN}"
+
+src_install() {
+ distutils_src_install
+ dohtml ${PN}.html
+ doman ${PN}.1
+}